summaryrefslogtreecommitdiff
path: root/libnm/Makefile.am
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2016-04-05 21:18:43 +0200
committerLubomir Rintel <lkundrak@v3.sk>2016-04-05 22:22:58 +0200
commit9152dec99f479d82400f464ab47d45b8cbd8e0eb (patch)
treeb5d135bd5302fbb2757c3b0bf1052a7156b8115c /libnm/Makefile.am
parent29cfb144a8cdfce697c63175b1bfa36e0d95a6ad (diff)
downloadNetworkManager-9152dec99f479d82400f464ab47d45b8cbd8e0eb.tar.gz
build: disable deprecation checks for internal compilation
For internal compilation we want to be able to use deprecated API without warnings. Define the version min/max macros to effectively disable deprecation warnings. However, don't do it via CFLAGS option in the makefiles, instead hack it to "nm-default.h". After all, *every* source file that is for internal compilation needs to include this header as first.
Diffstat (limited to 'libnm/Makefile.am')
-rw-r--r--libnm/Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/libnm/Makefile.am b/libnm/Makefile.am
index adf159d7df..e035b3cda2 100644
--- a/libnm/Makefile.am
+++ b/libnm/Makefile.am
@@ -14,7 +14,6 @@ AM_CPPFLAGS = \
-I$(top_builddir)/libnm \
-DG_LOG_DOMAIN=\""libnm"\" \
-DNETWORKMANAGER_COMPILATION=NM_NETWORKMANAGER_COMPILATION_LIB \
- -DNM_VERSION_MAX_ALLOWED=NM_VERSION_NEXT_STABLE \
$(GLIB_CFLAGS) \
$(GUDEV_CFLAGS) \
-DNMRUNDIR=\"$(nmrundir)\" \
@@ -133,7 +132,7 @@ libnm_la_SOURCES = \
GLIB_GENERATED = nm-enum-types.h nm-enum-types.c
nm_enum_types_sources = $(libnminclude_HEADERS)
GLIB_MKENUMS_H_FLAGS = --identifier-prefix NM --fhead '\#include <nm-core-enum-types.h>\n'
-GLIB_MKENUMS_C_FLAGS = --identifier-prefix NM
+GLIB_MKENUMS_C_FLAGS = --identifier-prefix NM --fhead '\#include "nm-default.h"\n'
libnm_la_LIBADD = \
$(top_builddir)/libnm-core/libnm-core.la \