summaryrefslogtreecommitdiff
path: root/libnm-util/Makefile.am
diff options
context:
space:
mode:
authorAlberto Ruiz <alberto.ruiz@canonical.com>2012-06-01 19:44:19 +0100
committerDan Williams <dcbw@redhat.com>2012-06-01 13:57:00 -0500
commitddb28d3e1a5b96d3e99e8dfeccc42ad3052ba0f6 (patch)
tree399f8d3da5cb94a85c50968c1a3f33a7f71ad902 /libnm-util/Makefile.am
parenteb460b70dad82d366d35fa5703c0e79a1389e4d1 (diff)
downloadNetworkManager-ddb28d3e1a5b96d3e99e8dfeccc42ad3052ba0f6.tar.gz
introspection: removes redudant package names from gir files (bgo #677296)
Currently the .gir files for NetworkManager-1.0 and NMClient-1.0 declare their dependencies twice, once with the GIR name and another one with the pkg-config name. This causes problems with Vala bindings generation.
Diffstat (limited to 'libnm-util/Makefile.am')
-rw-r--r--libnm-util/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/libnm-util/Makefile.am b/libnm-util/Makefile.am
index c4ea954554..680681e227 100644
--- a/libnm-util/Makefile.am
+++ b/libnm-util/Makefile.am
@@ -149,6 +149,7 @@ introspection_sources = $(libnm_util_include_HEADERS) $(libnm_util_la_csources)
NetworkManager-1.0.gir: libnm-util.la
NetworkManager_1_0_gir_INCLUDES = GObject-2.0 DBusGLib-1.0
NetworkManager_1_0_gir_PACKAGES = gobject-2.0 dbus-glib-1
+NetworkManager_1_0_gir_EXPORT_PACKAGES = libnm-util
NetworkManager_1_0_gir_CFLAGS = $(INCLUDES) -I$(top_srcdir)/libnm-util
NetworkManager_1_0_gir_LIBS = libnm-util.la
NetworkManager_1_0_gir_FILES = $(introspection_sources)