summaryrefslogtreecommitdiff
path: root/libnm-util/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@gnome.org>2014-06-27 12:28:35 -0400
committerDan Winship <danw@gnome.org>2014-06-27 17:24:58 -0400
commit9f82c1655709c5b813a3d90270bd6faa172e2577 (patch)
tree3ddd308313cd43c4431ff1a55e98eb8093e0470c /libnm-util/Makefile.am
parent377f72a66f0f3794780da77aa3090fd575639b43 (diff)
downloadNetworkManager-9f82c1655709c5b813a3d90270bd6faa172e2577.tar.gz
libnm-util: build nm-setting-docs.xml against uninstalled libnm-util
Set GI_TYPELIB_PATH and LD_LIBRARY_PATH so that we build nm-setting-docs.xml against the just-built typelib and .so, not the installed ones.
Diffstat (limited to 'libnm-util/Makefile.am')
-rw-r--r--libnm-util/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/libnm-util/Makefile.am b/libnm-util/Makefile.am
index c01dadc55d..eae7b5b064 100644
--- a/libnm-util/Makefile.am
+++ b/libnm-util/Makefile.am
@@ -189,7 +189,9 @@ if BUILD_SETTING_DOCS
noinst_DATA = nm-setting-docs.xml
nm-setting-docs.xml: generate-setting-docs.py NetworkManager-1.0.gir libnm-util.la
- $(srcdir)/generate-setting-docs.py \
+ export GI_TYPELIB_PATH=$(abs_builddir)$${GI_TYPELIB_PATH:+:$$GI_TYPELIB_PATH}; \
+ export LD_LIBRARY_PATH=$(abs_builddir)/.libs$${LD_LIBRARY_PATH:+:$$LD_LIBRARY_PATH}; \
+ strace -o /tmp/strace.out $(srcdir)/generate-setting-docs.py \
--gir $(builddir)/NetworkManager-1.0.gir \
--output $@