summaryrefslogtreecommitdiff
path: root/libnm-util/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@gnome.org>2014-07-15 11:37:19 -0400
committerDan Winship <danw@gnome.org>2014-07-15 11:37:19 -0400
commit30c74c6007bb0f9d9153fecc45208f2a1e811321 (patch)
tree4c5650ecb3e0965e7daaca2be2a841c47b9f9bb3 /libnm-util/Makefile.am
parentc9e2c34029ecfa2dda98c23c0e3d5fd1a67bddbe (diff)
downloadNetworkManager-30c74c6007bb0f9d9153fecc45208f2a1e811321.tar.gz
build: more srcdir!=builddir fixes
nm-version.h was getting disted, making srcdir!=builddir work for tarball builds, but not for git builds. Also, remove "-I${top_builddir}/include" from all Makefile.ams, since there's nothing generated in include/ any more.
Diffstat (limited to 'libnm-util/Makefile.am')
-rw-r--r--libnm-util/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/libnm-util/Makefile.am b/libnm-util/Makefile.am
index cb08a14b4f..79c3706b85 100644
--- a/libnm-util/Makefile.am
+++ b/libnm-util/Makefile.am
@@ -5,7 +5,6 @@ SUBDIRS = . tests
AM_CPPFLAGS = \
-I${top_srcdir} \
-I${top_srcdir}/include \
- -I${top_builddir}/include \
-DG_LOG_DOMAIN=\""libnm-util"\" \
-DNM_VERSION_MAX_ALLOWED=NM_VERSION_NEXT_STABLE \
$(GLIB_CFLAGS) \
@@ -53,8 +52,10 @@ libnm_util_include_HEADERS = \
nm-setting-wireless.h \
nm-setting-wireless-security.h \
nm-setting-vpn.h \
+ nm-utils.h
+
+nodist_libnm_util_include_HEADERS = \
nm-utils-enum-types.h \
- nm-utils.h \
nm-version.h
libnm_util_la_private_headers = \
@@ -163,7 +164,7 @@ INTROSPECTION_SCANNER_ARGS = --add-include-path=$(srcdir)
INTROSPECTION_COMPILER_ARGS = --includedir=$(srcdir)
if HAVE_INTROSPECTION
-introspection_sources = $(libnm_util_include_HEADERS) $(libnm_util_la_csources)
+introspection_sources = $(libnm_util_include_HEADERS) $(nodist_libnm_util_include_HEADERS) $(libnm_util_la_csources)
NetworkManager-1.0.gir: libnm-util.la
NetworkManager_1_0_gir_INCLUDES = GObject-2.0 DBusGLib-1.0