summaryrefslogtreecommitdiff
path: root/libnm-glib/tests/Makefile.am
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2015-02-09 12:42:36 +0100
committerThomas Haller <thaller@redhat.com>2015-02-09 12:51:43 +0100
commit2f595aba803f889e77f63529301be57aaf8a0b70 (patch)
tree125e830e4adb77a2d14a08a46077e8815dc727b1 /libnm-glib/tests/Makefile.am
parentf124848b6009bf8578146915494aa0cfa7f64234 (diff)
parentcfa45600733a91b774d436d66d0e6a446a18834c (diff)
downloadNetworkManager-2f595aba803f889e77f63529301be57aaf8a0b70.tar.gz
core: merge branch 'th/memleaks'
Fix memleaks and enable valgrind checks for most unit tests except ifupdown plugin. For ifupdown tests, there are some leaks that are not yet fixed. This is still to do. To run checks with valgrind, configure with --with-valgrind. Especially for libnm and libnm-glib tests, there are several leaks that are (probably?) not the fault of NetworkManager code. Hence, several suppressions were added to valgrind.suppressions. On different systems and different version of glib, these suppressions might not match and the test will fail there. The valgrind.suppressions should be reviewed, cleaned up and adjusted for more systems (and different glib library versions).
Diffstat (limited to 'libnm-glib/tests/Makefile.am')
-rw-r--r--libnm-glib/tests/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/libnm-glib/tests/Makefile.am b/libnm-glib/tests/Makefile.am
index 7b8f3627e2..6ce91dd931 100644
--- a/libnm-glib/tests/Makefile.am
+++ b/libnm-glib/tests/Makefile.am
@@ -12,6 +12,11 @@ AM_CPPFLAGS = \
noinst_PROGRAMS = $(TESTS)
+if WITH_VALGRIND
+@VALGRIND_RULES@ --launch-dbus
+else
+TESTS_ENVIRONMENT = $(srcdir)/libnm-test-launch.sh
+endif
TESTS = test-nm-client test-remote-settings-client
####### NMClient and non-settings tests #######
@@ -42,8 +47,6 @@ test_remote_settings_client_LDADD = \
###########################################
-TESTS_ENVIRONMENT = $(srcdir)/libnm-glib-test-launch.sh
-
endif
EXTRA_DIST = libnm-glib-test-launch.sh