summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBeniamino Galvani <bgalvani@redhat.com>2018-09-07 16:55:54 +0200
committerBeniamino Galvani <bgalvani@redhat.com>2018-09-13 14:35:15 +0200
commit4fd662316165bcd603664ab9bc60ad0ee96037f9 (patch)
treee6920ae1fa12c98108dac085620b855936abfefd /configure.ac
parentb66607af957e5beb8ffa063303bb8ab692a5fd05 (diff)
downloadNetworkManager-4fd662316165bcd603664ab9bc60ad0ee96037f9.tar.gz
build: move paths of dhcp clients from config-extra.h to config.h
Some path variable like $(bindir), $(datadir), etc. are special for autotools and must be handled separately through config-extra.h. But dhcp path variables are just normal variables defined through the configure script and should go into config.h. (cherry picked from commit 087c367d626a4c5b58dae5bc11670f3ab34b0e44)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index b41def3134..22d3e2acfe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -822,7 +822,7 @@ if test "$with_dhcpcanon" != "no"; then
fi
if test "$with_dhcpcanon" != "no"; then
AC_DEFINE(WITH_DHCPCANON, 1, [Define if you have dhcpcanon])
- AC_SUBST(DHCPCANON_PATH, $with_dhcpcanon)
+ AC_DEFINE_UNQUOTED(DHCPCANON_PATH, "$with_dhcpcanon", [Define path to dhcpcanon])
else
AC_DEFINE(WITH_DHCPCANON, 0, [Define if you have dhcpcanon])
fi
@@ -855,7 +855,7 @@ if test "$with_dhclient" != "no"; then
fi
if test "$with_dhclient" != "no"; then
AC_DEFINE(WITH_DHCLIENT, 1, [Define if you have dhclient])
- AC_SUBST(DHCLIENT_PATH, $with_dhclient)
+ AC_DEFINE_UNQUOTED(DHCLIENT_PATH, "$with_dhclient", [Define path to dhclient])
else
AC_DEFINE(WITH_DHCLIENT, 0, [Define if you have dhclient])
fi
@@ -874,7 +874,7 @@ if test "$with_dhcpcd" != "no"; then
fi
if test "$with_dhcpcd" != "no"; then
AC_DEFINE(WITH_DHCPCD, 1, [Define if you have dhcpcd])
- AC_SUBST(DHCPCD_PATH, $with_dhcpcd)
+ AC_DEFINE_UNQUOTED(DHCPCD_PATH, "$with_dhcpcd", [Define path to dhcpcd])
else
AC_DEFINE(WITH_DHCPCD, 0, [Define if you have dhcpcd])
fi