summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2018-09-11 16:06:25 +0200
committerThomas Haller <thaller@redhat.com>2018-10-25 16:37:35 +0200
commit50e092a967e3e8baac75dd09f69ec2a94f70f889 (patch)
tree16e5812635fa757688e36e892f1aede9d59bb5aa /configure.ac
parentec37e18c64ac480fc7c7699e45005894c27c8416 (diff)
downloadNetworkManager-50e092a967e3e8baac75dd09f69ec2a94f70f889.tar.gz
build: add configure check for having memfd_create() API
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 946f6b35e5..aac2a32340 100644
--- a/configure.ac
+++ b/configure.ac
@@ -81,6 +81,12 @@ AC_CHECK_DECLS([
#include <malloc.h>
]])
+AC_CHECK_DECLS([
+ memfd_create],
+ [], [], [[
+#include <sys/mman.h>
+]])
+
AC_CHECK_HEADERS(sys/auxv.h)
AC_CHECK_DECLS([getrandom],