summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLubomir Rintel <lkundrak@v3.sk>2015-05-14 14:45:45 +0200
committerLubomir Rintel <lkundrak@v3.sk>2015-05-26 13:51:45 +0200
commit380ed633180a1e20cb70b2cfde482a1cda8278e0 (patch)
treedcfaff2f755e5259e8b7b933605ba5529a58b082 /configure.ac
parent14f4674f64310509a18dc2812759d8f77994b70f (diff)
downloadNetworkManager-380ed633180a1e20cb70b2cfde482a1cda8278e0.tar.gz
build: switch to parallel test harness
This will make it possible to use the TAP formatter.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 2 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index f51e09e94a..54faece6d9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,20 +16,7 @@ AC_CONFIG_HEADERS([config.h])
AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_AUX_DIR([build-aux])
-dnl Initialize automake. automake < 1.12 didn't have serial-tests and
-dnl gives an error if it sees this, but for automake >= 1.13
-dnl serial-tests is required so we have to include it. Solution is to
-dnl test for the version of automake (by running an external command)
-dnl and provide it if necessary. Note we have to do this entirely using
-dnl m4 macros since automake queries this macro by running
-dnl 'autoconf --trace ...'.
-m4_define([serial_tests], [
- m4_esyscmd([automake --version |
- head -1 |
- awk '{split ($NF,a,"."); if (a[1] == 1 && a[2] >= 12) { print "serial-tests" }}'
- ])
-])
-AM_INIT_AUTOMAKE(1.11 serial_tests tar-ustar no-dist-gzip dist-bzip2 -Wno-portability) dnl NB: Do not [quote] this parameter.
+AM_INIT_AUTOMAKE(1.12 tar-ustar no-dist-gzip dist-bzip2 -Wno-portability) dnl NB: Do not [quote] this parameter.
AM_MAINTAINER_MODE([enable])
AM_SILENT_RULES([yes])
@@ -868,7 +855,7 @@ else
fi
fi
AS_IF([test "$with_valgrind" != "no"],
- AC_SUBST(VALGRIND_RULES, 'TESTS_ENVIRONMENT = "$(top_srcdir)/tools/run-test-valgrind.sh" "$(LIBTOOL)" "$(with_valgrind)" '"$with_valgrind_suppressions"),
+ AC_SUBST(VALGRIND_RULES, 'LOG_COMPILER = "$(top_srcdir)/tools/run-test-valgrind.sh" "$(LIBTOOL)" "$(with_valgrind)" '"$with_valgrind_suppressions"),
AC_SUBST(VALGRIND_RULES, []))
AM_CONDITIONAL(WITH_VALGRIND, test "${with_valgrind}" != "no")