summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBeniamino Galvani <bgalvani@redhat.com>2018-09-04 08:25:07 +0200
committerBeniamino Galvani <bgalvani@redhat.com>2018-09-18 15:32:36 +0200
commit691c71a7f2a1d2816a11165480e45355dcf032cb (patch)
treeb646fc278de877c42d31dd71b921944741867b54 /configure.ac
parentd9a4b59c18e36f2b577744b7fe6710d71161ca12 (diff)
downloadNetworkManager-691c71a7f2a1d2816a11165480e45355dcf032cb.tar.gz
build: allow disabling eBPF support in n-acdbg/n-acd-update
Add a configure option to disable eBPF support in n-acd. Note that, even if eBPF is not supported, n-acd requires a kernel > 3.19, which means that the setsockopt(..., SO_ATTACH_BPF) option must be defined. To allow building on older kernels without modifying the n-acd code, we inject the SO_ATTACH_BPF value as a preprocessor define in the compiler the command line.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e080d359cc..a8b0083e5f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -518,6 +518,15 @@ case $with_suspend_resume in
;;
esac
+# eBPF support
+AC_ARG_WITH(ebpf,
+ AS_HELP_STRING([--with-ebpf=yes|no], [Build with eBPF support (default: yes)]),
+ [], [with_ebpf=yes])
+if test "$with_ebpf" != "yes" -a "$with_ebpf" != "no"; then
+ AC_MSG_ERROR(--with-ebpf must be one of [yes, no])
+fi
+AM_CONDITIONAL(WITH_EBPF, test "${with_ebpf}" = "yes")
+
# SELinux support
AC_ARG_WITH(selinux,
AS_HELP_STRING([--with-selinux=yes|no|auto], [Build with SELinux (default: auto)]),
@@ -1353,4 +1362,5 @@ echo " JSON validation for libnm: $enable_json_validation"
echo " crypto: $with_crypto (have-gnutls: $have_crypto_gnutls, have-nss: $have_crypto_nss)"
echo " sanitizers: $sanitizers"
echo " Mozilla Public Suffix List: $with_libpsl"
+echo " eBPF: $with_ebpf"
echo