summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2019-04-09 17:24:59 +0200
committerThomas Haller <thaller@redhat.com>2019-04-09 17:24:59 +0200
commit52ea426b81e758819beb7850a590058f740706ab (patch)
tree9cad812c767085097e365d0a2c8435bc2170d33d /configure.ac
parent0d16b037f546bf8f251ab30f47a0a06657fd098b (diff)
downloadNetworkManager-52ea426b81e758819beb7850a590058f740706ab.tar.gz
build: disable eBPF by default
We have random failures to build on gitlab-ci. Something is wrong, at least, eBPF is not working reliably. Disable it for now.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a44236512a..c43f8f1cd4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -529,7 +529,8 @@ esac
AC_ARG_WITH(ebpf,
AS_HELP_STRING([--with-ebpf=yes|no|auto], [Build with eBPF support (default: auto)]),
[], [with_ebpf=auto])
-if test "$with_ebpf" = "yes" -o "$with_ebpf" = "auto"; then
+# 'auto' means 'false' because there are still some issues.
+if test "$with_ebpf" = "yes" ; then
AC_CHECK_HEADER(linux/bpf.h, [have_ebpf=yes], [have_ebpf=no])
else
have_ebpf=no