summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLubomir Rintel <lkundrak@v3.sk>2019-03-05 08:44:57 +0100
committerLubomir Rintel <lkundrak@v3.sk>2019-03-19 17:15:15 +0100
commit1de8383ad9fdfc8f552117e5d109bdfa7005634b (patch)
tree7b44996c8430157f2739b18148952859ea9e6b5f /configure.ac
parent32e0bf1421263b07a1dde74d9281253cc1ea49ab (diff)
downloadNetworkManager-1de8383ad9fdfc8f552117e5d109bdfa7005634b.tar.gz
all: goodbye libnm-glib
This removes libnm-glib, libnm-glib-vpn, and libnm-util for good. The it has been replaced with libnm since NetworkManager 1.0, disabled by default since 1.12 and no up-to-date distributions ship it for years now. Removing the libraries allows us to: * Remove the horrible hacks that were in place to deal with accidental use of both the new and old library in a single process. * Relief the translators of maintenance burden of similar yet different strings. * Get rid of known bad code without chances of ever getting fixed (libnm-glib/nm-object.c and libnm-glib/nm-object-cache.c) * Generally lower the footprint of the releases and our workspace If there are some really really legacy users; they can just build libnm-glib and friends from the NetworkManager-1.16 distribution. The D-Bus API is stable and old libnm-glib will keep working forever. https://github.com/NetworkManager/NetworkManager/pull/308
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac36
1 files changed, 0 insertions, 36 deletions
diff --git a/configure.ac b/configure.ac
index 1c00e4b81b..334d9272db 100644
--- a/configure.ac
+++ b/configure.ac
@@ -256,34 +256,6 @@ AC_SUBST(GLIB_LIBS)
GOBJECT_INTROSPECTION_CHECK([0.9.6])
-AC_ARG_WITH(libnm-glib,
- AS_HELP_STRING([--with-libnm-glib],
- [build legacy libraries]))
-fake_typelibs=no
-if test "$with_libnm_glib" == "yes"; then
- PKG_CHECK_MODULES(DBUS, dbus-1 >= 1.1 dbus-glib-1 >= 0.94, :,
- [AC_MSG_FAILURE([$DBUS_PKG_ERRORS
-
-Configure with --without-libnm-glib if you do not need the legacy libraries])
- ])
-
- if test "${found_introspection}" = "yes"; then
- AC_PATH_PROG(GLIB_COMPILE_RESOURCES, glib-compile-resources)
- if ! test x"$GLIB_COMPILE_RESOURCES" = x""; then
- fake_typelibs=yes
- fi
- fi
-else
- with_libnm_glib=no
-fi
-AM_CONDITIONAL(WITH_LEGACY_LIBRARIES, test "$with_libnm_glib" == "yes")
-if test "$fake_typelibs" = "yes"; then
- AC_DEFINE(WITH_FAKE_TYPELIBS, 1, [Define for libnm to prevent GIR from loading libnm-glib])
-else
- AC_DEFINE(WITH_FAKE_TYPELIBS, 0, [Define for libnm to prevent GIR from loading libnm-glib])
-fi
-AM_CONDITIONAL(WITH_FAKE_TYPELIBS, test "${fake_typelibs}" = "yes")
-
PKG_CHECK_MODULES([LIBUDEV], [libudev >= 175])
# Qt4
@@ -1274,17 +1246,10 @@ AC_CONFIG_FILES([
Makefile
shared/nm-version-macros.h
libnm/libnm.pc
-libnm-util/libnm-util.pc
-libnm-glib/libnm-glib.pc
-libnm-glib/libnm-glib-vpn.pc
po/Makefile.in
data/org.freedesktop.NetworkManager.policy.in
docs/api/Makefile
docs/api/version.xml
-docs/libnm-glib/Makefile
-docs/libnm-glib/version.xml
-docs/libnm-util/Makefile
-docs/libnm-util/version.xml
docs/libnm/Makefile
docs/libnm/version.xml
NetworkManager.pc
@@ -1333,7 +1298,6 @@ echo " ofono: $with_ofono"
echo " concheck: $enable_concheck"
echo " libteamdctl: $enable_teamdctl"
echo " ovs: $enable_ovs"
-echo " libnm-glib: $with_libnm_glib"
echo " nmcli: $build_nmcli"
echo " nmtui: $build_nmtui"
echo " iwd: $ac_with_iwd"