summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2013-01-18 14:35:27 -0500
committerDan Winship <danw@gnome.org>2013-01-22 12:49:48 -0500
commitae627737d5f370b3584fb07bf8f041226611148b (patch)
tree84740fa94aa61eae182c8a801fe5dcfbd059d8f7 /configure.ac
parente7caad20c9b30594fc0f700e98a6576e577a764b (diff)
downloadNetworkManager-ae627737d5f370b3584fb07bf8f041226611148b.tar.gz
Remove SIGSEGV/SIGFPE etc. handling
Modern operating systems come with systemwide "crash catching" facilities; for example, the Linux kernel can now pipe core dumps out to userspace, and programs like "systemd-coredump" and "abrt" record these. In this model, it's actively counterproductive for individual processes to catch SIGSEGV because: 1) Trying to unwind from inside the process after arbitrary corruption is destined to fail. 2) It hides the fact that a crash happened at all - my OS test framework wants to know if any process crashed, and I don't want to guess by running regexps against /var/log/Xorg.0.log or whatever. Signed-off-by: Colin Walters <walters@verbum.org> https://bugzilla.gnome.org/show_bug.cgi?id=692032
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 0 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index dbbc1fdc08..51582917a6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -611,13 +611,6 @@ fi
AC_DEFINE_UNQUOTED(KERNEL_FIRMWARE_DIR, "$KERNEL_FIRMWARE_DIR", [Define to path of the kernel firmware directory])
AC_SUBST(KERNEL_FIRMWARE_DIR)
-AC_ARG_ENABLE(crashtrace,
- AS_HELP_STRING([--disable-crashtrace], [Disable GNU backtrace extensions]),
- [enable_crashtrace=${enableval}], [enable_crashtrace=yes])
-if test x"$enable_crashtrace" = xyes; then
- AC_DEFINE(ENABLE_CRASHTRACE, 1, [Define if you have GNU backtrace extensions])
-fi
-
PKG_CHECK_MODULES(LIBSOUP, [libsoup-2.4 >= 2.26], [have_libsoup=yes],[have_libsoup=no])
AC_ARG_ENABLE(concheck, AS_HELP_STRING([--enable-concheck], [enable connectivity checking support]),
[enable_concheck=${enableval}], [enable_concheck=${have_libsoup}])