summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2013-09-20 20:48:45 +0200
committerThomas Haller <thaller@redhat.com>2013-09-25 21:01:04 +0200
commitb246788bc46cf7e9fe4d7d802f17f18c50acece5 (patch)
tree947b8a4c4f914187cfcdfee5709d11b106c50094 /configure.ac
parentcfd4d5209cac4e850ed07a8f935690e2c8841f41 (diff)
downloadNetworkManager-b246788bc46cf7e9fe4d7d802f17f18c50acece5.tar.gz
config: make BlueZ 5 default and replace --enable-bluez5 with --enable-bluez4
Build now BlueZ 5 by default and rename the configure flag --enable-bluez5 to --enable-bluez4. Signed-off-by: Thomas Haller <thaller@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 8 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index c17db5d4f6..424c904f6b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -268,15 +268,15 @@ fi
AC_SUBST(UDEV_BASE_DIR)
# BlueZ
-AC_ARG_ENABLE(bluez5, AS_HELP_STRING([--enable-bluez5],
- [build with BlueZ 5 support instead of BlueZ 4]),
- [enable_bluez5=${enableval}])
-if (test "${enable_bluez5}" = "yes"); then
- AC_DEFINE(WITH_BLUEZ5, 1, [Define if you have BlueZ 5 support])
+AC_ARG_ENABLE(bluez4, AS_HELP_STRING([--enable-bluez4],
+ [build with BlueZ 4 support instead of BlueZ 5]),
+ [enable_bluez4=${enableval}])
+if (test "${enable_bluez4}" = "yes"); then
+ AC_DEFINE(WITH_BLUEZ4, 1, [Define if you have BlueZ 4 support])
else
- AC_DEFINE(WITH_BLUEZ5, 0, [Define if you have BlueZ 5 support])
+ AC_DEFINE(WITH_BLUEZ4, 0, [Define if you have BlueZ 4 support])
fi
-AM_CONDITIONAL(WITH_BLUEZ5, test "${enable_bluez5}" = "yes")
+AM_CONDITIONAL(WITH_BLUEZ4, test "${enable_bluez4}" = "yes")
# systemd unit support
AC_ARG_WITH([systemdsystemunitdir], AS_HELP_STRING([--with-systemdsystemunitdir=DIR],
@@ -825,7 +825,7 @@ echo " modemmanager-1: $with_modem_manager_1"
echo " concheck: $enable_concheck"
echo " libndp: $libndp_location"
echo " libteamdctl: $enable_teamdctl"
-echo " bluez 5: $enable_bluez5"
+echo " bluez 4: $enable_bluez4"
echo
echo "Configuration plugins"