summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Winship <danw@gnome.org>2014-05-30 16:45:02 -0400
committerDan Winship <danw@gnome.org>2014-06-19 17:45:02 -0400
commit8252ebd941d17fff932023d29aac0bfe436d4bf9 (patch)
tree4265f41a53a7145c8d5259d2515cd0885e2f4cf7 /configure.ac
parent07bb19a3bb32f45fd05dae94e7f6b101e05343d8 (diff)
downloadNetworkManager-8252ebd941d17fff932023d29aac0bfe436d4bf9.tar.gz
cli: generate setting docs from libnm-util/nm-setting-docs.xml
nmcli used the GParamSpec doc strings to get property descriptions, but they will be going away. Generate a .c file from the new XML setting docs file, and link that into nmcli.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6d1885ea1b..c1f583ebf7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -267,6 +267,9 @@ AC_SUBST(GUDEV_CFLAGS)
AC_SUBST(GUDEV_LIBS)
GOBJECT_INTROSPECTION_CHECK([0.9.6])
+if test -z "$INTROSPECTION_MAKEFILE"; then
+ AC_DEFINE(HAVE_INTROSPECTION, [1], [Define if you have gobject-introspection])
+fi
# Qt4
PKG_CHECK_MODULES(QT, [QtCore >= 4 QtDBus QtNetwork], [have_qt=yes],[have_qt=no])