summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBeniamino Galvani <bgalvani@redhat.com>2020-05-08 09:09:25 +0200
committerBeniamino Galvani <bgalvani@redhat.com>2020-05-15 19:06:24 +0200
commitc8b5bf402d20077a73c15d55fc90c26e97119711 (patch)
tree846e71c73745e74f68e20a5bcb44e231ff460e85 /configure.ac
parentfb0d59689c0d55c3592129c1161772550df79073 (diff)
downloadNetworkManager-c8b5bf402d20077a73c15d55fc90c26e97119711.tar.gz
build: install a firewalld zone for shared mode
Install a NM-specific firewalld zone to be used for interfaces that are used for connection sharing. The zone blocks all traffic to the local machine except some protocols (DHCP, DNS and ICMP) and allows all forwarded traffic.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 960f957afd..5b11a13b76 100644
--- a/configure.ac
+++ b/configure.ac
@@ -673,6 +673,18 @@ else
fi
AC_SUBST(NM_MODIFY_SYSTEM_POLICY)
+AC_ARG_ENABLE(firewalld-zone,
+ AS_HELP_STRING([--enable-firewalld-zone], [Install and use firewalld zone for shared mode]),
+ [enable_firewalld_zone=${enableval}],
+ [enable_firewalld_zone=yes])
+
+if test "${enable_firewalld_zone}" = "yes"; then
+ AC_DEFINE(WITH_FIREWALLD_ZONE, 1, [Define if NetworkManager uses a custom zone for shared mode])
+else
+ AC_DEFINE(WITH_FIREWALLD_ZONE, 0, [Define if NetworkManager uses a custom zone for shared mode])
+fi
+AM_CONDITIONAL(WITH_FIREWALLD_ZONE, test "${enable_firewalld_zone}" = "yes")
+
PKG_CHECK_MODULES(GNUTLS, [gnutls >= 2.12], [have_crypto_gnutls=yes], [have_crypto_gnutls=no])
PKG_CHECK_MODULES(NSS, [nss], [have_crypto_nss=yes], [have_crypto_nss=yes])
if test "${have_crypto_nss}" = "yes"; then
@@ -1370,6 +1382,7 @@ echo "Miscellaneous:"
echo " have introspection: $have_introspection"
echo " build documentation and manpages: $build_docs"
echo " install pregenerated documentation and manpages: $use_pregen_docs"
+echo " install and use firewalld shared zone: $enable_firewalld_zone"
echo " tests: $enable_tests"
echo " more-asserts: $more_asserts"
echo " more-logging: $enable_more_logging"