summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPavel Šimerda <psimerda@redhat.com>2012-12-28 19:21:25 +0100
committerPavel Šimerda <psimerda@redhat.com>2012-12-28 19:21:25 +0100
commita787e5c585a0dfb235604f971368b5517735f872 (patch)
treebf07731e7bedb325c3450ee947024c86928e2ee9 /configure.ac
parent1208f6e512c97807b5a0a841907592797dd2f1eb (diff)
downloadNetworkManager-a787e5c585a0dfb235604f971368b5517735f872.tar.gz
build: cleanups
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac68
1 files changed, 20 insertions, 48 deletions
diff --git a/configure.ac b/configure.ac
index 986665932a..40d703a1ec 100644
--- a/configure.ac
+++ b/configure.ac
@@ -767,8 +767,27 @@ echo " nmstatedir: $nmstatedir"
echo " nmrundir: $nmrundir"
echo
-echo "Platform interaction:"
+echo "Platform:"
echo " libnl: $with_libnl"
+echo " session tracking: $with_session_tracking"
+echo " suspend/resume: $with_suspend_resume"
+if test "${enable_polkit}" = "yes"; then
+ if test "${enable_modify_system}"; then
+ echo " policykit: yes (permissive modify.system)"
+ else
+ echo " policykit: yes (restrictive modify.system)"
+ fi
+else
+ echo " policykit: no"
+fi
+echo
+
+echo "Features:"
+echo " wext: $ac_with_wext"
+echo " wimax: $enable_wimax"
+echo " ppp: $enable_ppp"
+echo " modemmanager-1: $with_modem_manager_1"
+echo " concheck: $enable_concheck"
echo
echo "Configuration plugins"
@@ -788,53 +807,6 @@ echo " dhclient: $with_dhclient"
echo " dhcpcd: $with_dhcpcd"
echo
-if test "${enable_polkit}" = "yes"; then
- if test "${enable_modify_system}"; then
- echo "PolicyKit support: yes (permissive modify.system)"
- else
- echo "PolicyKit support: yes (restrictive modify.system)"
- fi
-else
- echo PolicyKit support: no
-fi
-
- echo Session tracking: ${with_session_tracking}
-
- echo Suspend/resume: ${with_session_tracking}
-
-if test "${enable_wimax}" = "yes"; then
- echo WiMAX support: yes
-else
- echo WiMAX support: no
-fi
-
-if test "${enable_ppp}" = "yes"; then
- echo PPP support: yes
-else
- echo PPP support: no
-fi
-
-if test "${with_modem_manager_1}" = "yes"; then
- echo ModemManager1 support: yes
-else
- echo ModemManager1 support: no
-fi
-
-if test "${enable_concheck}" = "yes"; then
- echo Connectivity checking support: yes
-else
- echo Connectivity checking support: no
-fi
-
-echo libnl version: ${libnl_version}
-
-if test "${ac_with_wext}" = "yes"; then
- echo WEXT support: yes
-else
- echo WEXT support: no
-fi
-echo
-
echo "Miscellaneous:"
echo " documentation: $enable_doc"
echo " tests: $enable_tests"