summaryrefslogtreecommitdiff
path: root/clients/tui/meson.build
diff options
context:
space:
mode:
authorBeniamino Galvani <bgalvani@redhat.com>2019-03-31 11:36:09 +0200
committerBeniamino Galvani <bgalvani@redhat.com>2019-04-02 11:20:28 +0200
commit5b5a768b693a3685ee0acd3c9ea31d1f7ce70d19 (patch)
tree22d40a4f3cc81585aee216a5b17b7a881d741404 /clients/tui/meson.build
parent9c9c8c68ff1a729711f1334267383edabd7bdf6c (diff)
downloadNetworkManager-5b5a768b693a3685ee0acd3c9ea31d1f7ce70d19.tar.gz
clients: only ask secrets for settings that require them
When nmcli needs secrets for a connection it asks them for every known setting. nmtui is a bit smarter and asks them only for settings that actually exist in the connection. Make a step further and let clients ask secrets only for setting that exist *and* have any secret property. This decreases the number of D-Bus calls when editing or showing a connection with secrets. https://bugzilla.redhat.com/show_bug.cgi?id=1506536 https://github.com/NetworkManager/NetworkManager/pull/327
Diffstat (limited to 'clients/tui/meson.build')
-rw-r--r--clients/tui/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/clients/tui/meson.build b/clients/tui/meson.build
index 461b1f0a77..e7c44384fa 100644
--- a/clients/tui/meson.build
+++ b/clients/tui/meson.build
@@ -56,6 +56,7 @@ sources = files(
deps += [
libnm_dep,
+ libnmc_dep,
libnmc_base_dep,
libnmt_newt_dep,
]