summaryrefslogtreecommitdiff
path: root/clients/meson.build
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2018-01-10 10:29:11 +0100
committerThomas Haller <thaller@redhat.com>2018-01-10 12:31:44 +0100
commit349861ceec4085fd1f0ff0af8bcf873aa15ba611 (patch)
tree6543ad02add282e0c3c0a62d632d607f93659eaa /clients/meson.build
parentec016f6b43f4f7727944d67e358e7dc01ee2e42d (diff)
downloadNetworkManager-349861ceec4085fd1f0ff0af8bcf873aa15ba611.tar.gz
build/meson: unconditionally use linker version scripts
We also unconditionally use them with autotools. Also, the detection for have_version_script does not seem correct to me. At least, it didn't work with clang.
Diffstat (limited to 'clients/meson.build')
-rw-r--r--clients/meson.build7
1 files changed, 3 insertions, 4 deletions
diff --git a/clients/meson.build b/clients/meson.build
index f5e9c0eab2..efcaf299fb 100644
--- a/clients/meson.build
+++ b/clients/meson.build
@@ -14,10 +14,9 @@ cflags = clients_cflags + [
'-DG_LOG_DOMAIN="@0@"'.format(name),
]
-ldflags = []
-if have_version_script
- ldflags += '-Wl,--version-script,@0@'.format(linker_script_binary)
-endif
+ldflags = [
+ '-Wl,--version-script,@0@'.format(linker_script_binary),
+]
executable(
name,