summaryrefslogtreecommitdiff
path: root/clients/meson.build
diff options
context:
space:
mode:
authorIñigo Martínez <inigomartinez@gmail.com>2017-11-25 11:39:06 +0100
committerThomas Haller <thaller@redhat.com>2017-12-13 15:48:50 +0100
commit03637ad8b5d21fcc12a536a25caf46445aabde73 (patch)
tree3330fed2a9ad0f45c0c993a8aac6d3dee42ed101 /clients/meson.build
parente96fabfc186510808cee1bf6aaaa28f460f1cea5 (diff)
downloadNetworkManager-03637ad8b5d21fcc12a536a25caf46445aabde73.tar.gz
build: add initial support for meson build system
meson is a build system focused on speed an ease of use, which helps speeding up the software development. This patch adds meson support along autotools. [thaller@redhat.com: rebased patch and adjusted for iwd support] https://mail.gnome.org/archives/networkmanager-list/2017-December/msg00022.html
Diffstat (limited to 'clients/meson.build')
-rw-r--r--clients/meson.build44
1 files changed, 44 insertions, 0 deletions
diff --git a/clients/meson.build b/clients/meson.build
new file mode 100644
index 0000000000..6c00fc0a28
--- /dev/null
+++ b/clients/meson.build
@@ -0,0 +1,44 @@
+name = 'nm-online'
+
+incs = [
+ top_inc,
+ shared_inc,
+ libnm_core_inc
+]
+
+deps = [
+ glib_dep,
+ libnm_dep
+]
+
+cflags = [
+ '-DG_LOG_DOMAIN="@0@"'.format(name),
+ '-DNMLOCALEDIR="@0@"'.format(nm_localedir)
+]
+
+ldflags = []
+if have_version_script
+ ldflags += '-Wl,--version-script,@0@'.format(linker_script_binary)
+endif
+
+executable(
+ name,
+ [name + '.c', libnm_core_enums_h],
+ include_directories: incs,
+ dependencies: deps,
+ c_args: cflags,
+ link_args: ldflags,
+ link_depends: linker_script_binary,
+ install: true,
+ install_dir: nm_bindir
+)
+
+subdir('common')
+
+if enable_nmcli
+ subdir('cli')
+endif
+
+if enable_nmtui
+ subdir('tui')
+endif