summaryrefslogtreecommitdiff
path: root/clients/meson.build
diff options
context:
space:
mode:
authorIñigo Martínez <inigomartinez@gmail.com>2019-09-11 11:10:08 +0200
committerThomas Haller <thaller@redhat.com>2019-10-01 09:49:33 +0200
commit096748a196965ee781ac01b73b23e7d51b5459e6 (patch)
tree406490b9571c68363a61b387293485461932e2c7 /clients/meson.build
parent70da6993c878444cd3a95f81753594af87ea1793 (diff)
downloadNetworkManager-096748a196965ee781ac01b73b23e7d51b5459e6.tar.gz
meson: Rename cflags variable
The variable holding the compiler flags, `cflags`, has been renamed to `c_flags` to be consistent with the rest of build files. Different objects used in the `test-dispatcher-envp` target have been grouped together. The dependency over the `libnm` library has been removed as it is unnecessary.
Diffstat (limited to 'clients/meson.build')
-rw-r--r--clients/meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/clients/meson.build b/clients/meson.build
index 1c539d98ef..93aa9b15fa 100644
--- a/clients/meson.build
+++ b/clients/meson.build
@@ -5,11 +5,11 @@ deps = [
libnm_nm_default_dep,
]
-clients_cflags = [
+clients_c_flags = [
'-DNETWORKMANAGER_COMPILATION=NM_NETWORKMANAGER_COMPILATION_CLIENT',
]
-cflags = clients_cflags + [
+c_flags = clients_c_flags + [
'-DG_LOG_DOMAIN="@0@"'.format(name),
]
@@ -17,7 +17,7 @@ executable(
name,
name + '.c',
dependencies: deps,
- c_args: cflags,
+ c_args: c_flags,
link_args: ldflags_linker_script_binary,
link_depends: linker_script_binary,
install: true,