summaryrefslogtreecommitdiff
path: root/clients/cloud-setup/meson.build
diff options
context:
space:
mode:
authorAntonio Cardace <acardace@redhat.com>2020-06-18 18:30:13 +0200
committerAntonio Cardace <acardace@redhat.com>2020-06-26 16:47:56 +0200
commita2b699f40f29fb1d37cda8c9a10365229f55b0c8 (patch)
treedef85b9bab5ae75d3309d560bcbb7714c5bb0d5c /clients/cloud-setup/meson.build
parent75a84677caab9161e3b347ddc20a4b387873d048 (diff)
downloadNetworkManager-a2b699f40f29fb1d37cda8c9a10365229f55b0c8.tar.gz
nmcs-gcp: add support for Google Cloud Platform load balancers
This add a provider implementation for GCP that when detected fetches the ip addresses of configured internal load balancers. Once this information is fetched from the metadata server it instructs NetworkManager to add local routes for each found forwarded-ip. https://bugzilla.redhat.com/show_bug.cgi?id=1821787
Diffstat (limited to 'clients/cloud-setup/meson.build')
-rw-r--r--clients/cloud-setup/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/clients/cloud-setup/meson.build b/clients/cloud-setup/meson.build
index d8f96539e0..805d46813b 100644
--- a/clients/cloud-setup/meson.build
+++ b/clients/cloud-setup/meson.build
@@ -28,6 +28,7 @@ sources = files(
'nm-cloud-setup-utils.c',
'nm-http-client.c',
'nmcs-provider-ec2.c',
+ 'nmcs-provider-gcp.c',
'nmcs-provider.c',
)