summaryrefslogtreecommitdiff
path: root/callouts/Makefile.am
diff options
context:
space:
mode:
authorDan Williams <dcbw@redhat.com>2012-07-16 19:51:05 -0500
committerDan Williams <dcbw@redhat.com>2012-07-16 19:54:07 -0500
commit757a34fcdde7ef90dc59e05e60271be27505f0e9 (patch)
tree8b144e38d856a9624b4d9798645fc74af4cbeb5e /callouts/Makefile.am
parent00297f49fbbe05c51c02da43cda254c35e053589 (diff)
downloadNetworkManager-757a34fcdde7ef90dc59e05e60271be27505f0e9.tar.gz
callouts: remove glib code from DHCP callout
The whole callout is pure dbus, not dbus-glib, so there's really no need for glib code there. Even so, DBUS_LIBS contains dbus-glib and gobject, so we're still linking to glib/gobject.
Diffstat (limited to 'callouts/Makefile.am')
-rw-r--r--callouts/Makefile.am6
1 files changed, 1 insertions, 5 deletions
diff --git a/callouts/Makefile.am b/callouts/Makefile.am
index 616278592b..45d38b61ce 100644
--- a/callouts/Makefile.am
+++ b/callouts/Makefile.am
@@ -24,14 +24,10 @@ nm_dhcp_client_action_SOURCES = \
nm_dhcp_client_action_CPPFLAGS = \
$(DBUS_CFLAGS) \
- $(GLIB_CFLAGS) \
- -DG_DISABLE_DEPRECATED \
-DSYSCONFDIR=\"$(sysconfdir)\" \
-DLIBEXECDIR=\"$(libexecdir)\"
-nm_dhcp_client_action_LDADD = \
- $(DBUS_LIBS) \
- $(GLIB_LIBS)
+nm_dhcp_client_action_LDADD = $(DBUS_LIBS)
nm_avahi_autoipd_action_SOURCES = \