summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2020-06-19 12:36:49 +0200
committerThomas Haller <thaller@redhat.com>2020-06-19 12:46:20 +0200
commitc537852231a63431ee95ceb14968382e37e7aaea (patch)
tree1665d364fd131c7269871f28324828a1befdd746 /Makefile.am
parent9f77d26ad0ffaa51d9b262ea4d9b28bbc58b6f68 (diff)
downloadNetworkManager-c537852231a63431ee95ceb14968382e37e7aaea.tar.gz
build: optionally skip python black check by setting NMTST_SKIP_PYTHON_BLACK=1
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 71643080b0..db9f4c80c6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5235,9 +5235,10 @@ CLEANFILES += \
###############################################################################
include Makefile.examples
+
if WITH_PYTHON_BLACK
check-python-black:
- $(BLACK) --check $(top_srcdir)
+ test "$$NMTST_SKIP_PYTHON_BLACK" != 1 && $(BLACK) --check $(top_srcdir)
check_local += check-python-black
endif