summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2020-09-16 19:14:20 +0200
committerThomas Haller <thaller@redhat.com>2020-10-23 17:11:57 +0200
commit17269b05200aa565b5de7054a224e8ecd5b6aeca (patch)
tree79ef8b1dabdc2fef73201dd89c4d60883aab60f1 /Makefile.am
parent3caf419df650e4f6cca2a44b7968971c6d0780c5 (diff)
downloadNetworkManager-17269b05200aa565b5de7054a224e8ecd5b6aeca.tar.gz
l3cfg: add support for IPv4 link local addresses (ipv4ll) to NML3Cfg
NML3Cfg already handles IPv4 ACD. IPv4LL is just a small additional layer on top of that, so it makes sense that it also is handled by NML3Cfg. Also, the overall goal is that multiple NMDevice and NMVpnConnection instances can cooperate independently. So if multiple "users" enable IPv4LL on an interface, then we should only run it once. This is achieved by NML3IPv4LL's API where users register what they want, and NML3IPv4LL figures out what that means as a whole. Also, we thus will no longer need to use sd_ipv4ll/n-ipv4ll, because we implement it ourself.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0d02d3ff52..61437e4cbf 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2124,6 +2124,8 @@ src_libNetworkManagerBase_la_SOURCES = \
src/nm-netns.h \
src/nm-l3-config-data.c \
src/nm-l3-config-data.h \
+ src/nm-l3-ipv4ll.c \
+ src/nm-l3-ipv4ll.h \
src/nm-l3cfg.c \
src/nm-l3cfg.h \
src/nm-ip-config.c \