summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLubomir Rintel <lkundrak@v3.sk>2018-03-18 20:38:49 +0100
committerLubomir Rintel <lkundrak@v3.sk>2018-05-14 16:05:12 +0200
commit320422e4cf47e6ea36023294fa926f8c8c99d127 (patch)
treefa98f095bf4b57592e141b1a984ad7b52104648a /Makefile.am
parentbade13129bac52698d3add3658f39316e1a45f3f (diff)
downloadNetworkManager-320422e4cf47e6ea36023294fa926f8c8c99d127.tar.gz
build: qualify plugin dir name with a version string
This makes package updates more robust, avoiding in-place replaces of the plugins. Previously, if an upgrade transaction was terminated, NetworkManager library could end up being of a different version than the plugins. If the user was unfortunate enough to connect using a connection that required a plugin (say, Wi-Fi), he would be left without a network connection making it somewhat inconvenient to recover from the botched upgrade. This makes the whole situation a little bit less sad. The VPN plugins are kept where they always have been -- the path is not qualified with a version number.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 8 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 68faf421e1..1d5c8bfa06 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,7 +20,7 @@ sbin_PROGRAMS =
bin_PROGRAMS =
libexec_PROGRAMS =
lib_LTLIBRARIES =
-pkglib_LTLIBRARIES =
+plugin_LTLIBRARIES =
core_plugins =
service_DATA =
man_MANS =
@@ -73,6 +73,8 @@ examplesdir = $(docdir)/examples
rundir=$(runstatedir)/NetworkManager
statedir=$(localstatedir)/lib/NetworkManager
+plugindir=$(pkglibdir)/$(NM_DIST_VERSION)
+
dbusactivationdir = $(datadir)/dbus-1/system-services
servicedir = $(datadir)/dbus-1/system-services
@@ -578,7 +580,8 @@ libnm_core_libnm_core_la_CPPFLAGS = \
-DLOCALEDIR=\"$(datadir)/locale\" \
-DNMCONFDIR=\"$(nmconfdir)\" \
-DNMLIBDIR=\"$(nmlibdir)\" \
- -DNMPLUGINDIR=\"$(pkglibdir)\" \
+ -DNMVPNDIR=\"$(pkglibdir)\" \
+ -DNMPLUGINDIR=\"$(plugindir)\" \
-DLIBEXECDIR=\"$(libexecdir)\" \
$(NULL)
@@ -1190,7 +1193,7 @@ src_cppflags = \
\
-DNMCONFDIR=\"$(nmconfdir)\" \
-DNMLOCALEDIR=\"$(datadir)/locale\" \
- -DNMPLUGINDIR=\"$(pkglibdir)\" \
+ -DNMPLUGINDIR=\"$(plugindir)\" \
-DNMRUNDIR=\"$(nmrundir)\" \
-DNMSTATEDIR=\"$(nmstatedir)\" \
-DNMLIBDIR=\"$(nmlibdir)\" \
@@ -4745,7 +4748,7 @@ check_PROGRAMS += $(check_programs) $(check_programs_norun)
check_LTLIBRARIES += $(check_ltlibraries)
endif
-pkglib_LTLIBRARIES += $(core_plugins)
+plugin_LTLIBRARIES += $(core_plugins)
TESTS += $(check_programs)
@@ -4845,7 +4848,7 @@ install-data-hook: $(install_data_hook)
$(mkinstalldirs) -m 0755 $(DESTDIR)$(nmlibdir)/conf.d
$(mkinstalldirs) -m 0755 $(DESTDIR)$(nmlibdir)/VPN
$(mkinstalldirs) -m 0700 $(DESTDIR)$(nmstatedir)
- $(mkinstalldirs) -m 0755 $(DESTDIR)$(pkglibdir)
+ $(mkinstalldirs) -m 0755 $(DESTDIR)$(plugindir)
uninstall-hook: $(uninstall_hook)