summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2019-04-14 13:36:32 +0200
committerThomas Haller <thaller@redhat.com>2019-04-18 18:57:24 +0200
commitb434b9ec0794fc62a2469445d17debf645ba24cc (patch)
tree340dbfbce81b71903770f4a4a0d523efb6a7d595 /Makefile.am
parentdf3c7c3ff463a10a033fcc4bf516007d3c57bf92 (diff)
downloadNetworkManager-b434b9ec0794fc62a2469445d17debf645ba24cc.tar.gz
shared: split C-only helper "shared/nm-std-aux" utils out of "shared/nm-utils"
"shared/nm-utils" contains general purpose utility functions that only depend on glib (and extend glib with some helper functions). We will also add code that does not use glib, hence it would be good if the part of "shared/nm-utils" that does not depend on glib, could be used by these future projects. Also, we use the term "utils" everywhere. While that covers the purpose and content well, having everything called "nm-something-utils" is not great. Instead, call this "nm-std-aux", inspired by "c-util/c-stdaux".
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am35
1 files changed, 30 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 7796836e32..0deb49ea6a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -287,6 +287,35 @@ shared_libnacd_la_LIBADD = \
###############################################################################
+noinst_LTLIBRARIES += shared/nm-std-aux/libnm-std-aux.la
+
+shared_nm_std_aux_libnm_std_aux_la_CPPFLAGS = \
+ $(dflt_cppflags) \
+ -I$(srcdir)/shared \
+ $(CODE_COVERAGE_CFLAGS) \
+ $(SANITIZER_LIB_CFLAGS) \
+ -DG_LOG_DOMAIN=\""libnm"\" \
+ -DNETWORKMANAGER_COMPILATION='0' \
+ $(NULL)
+
+shared_nm_std_aux_libnm_std_aux_la_SOURCES = \
+ shared/c-list/src/c-list.h \
+ shared/nm-std-aux/c-list-util.c \
+ shared/nm-std-aux/c-list-util.h \
+ shared/nm-std-aux/unaligned.h \
+ $(NULL)
+
+shared_nm_std_aux_libnm_std_aux_la_LDFLAGS = \
+ $(CODE_COVERAGE_LDFLAGS) \
+ $(SANITIZER_LIB_LDFLAGS) \
+ $(NULL)
+
+shared_nm_std_aux_libnm_std_aux_la_LIBADD = \
+ shared/libcsiphash.la \
+ $(NULL)
+
+###############################################################################
+
shared_nm_utils_libnm_utils_cppflags = \
$(dflt_cppflags) \
-I$(srcdir)/shared \
@@ -304,9 +333,6 @@ shared_nm_utils_libnm_utils_base_la_CPPFLAGS = \
$(NULL)
shared_nm_utils_libnm_utils_base_la_SOURCES = \
- shared/c-list/src/c-list.h \
- shared/nm-utils/c-list-util.c \
- shared/nm-utils/c-list-util.h \
shared/nm-utils/nm-c-list.h \
shared/nm-utils/nm-dedup-multi.c \
shared/nm-utils/nm-dedup-multi.h \
@@ -330,7 +356,6 @@ shared_nm_utils_libnm_utils_base_la_SOURCES = \
shared/nm-utils/nm-shared-utils.h \
shared/nm-utils/nm-time-utils.c \
shared/nm-utils/nm-time-utils.h \
- shared/nm-utils/unaligned.h \
$(NULL)
shared_nm_utils_libnm_utils_base_la_LDFLAGS = \
@@ -339,7 +364,7 @@ shared_nm_utils_libnm_utils_base_la_LDFLAGS = \
$(NULL)
shared_nm_utils_libnm_utils_base_la_LIBADD = \
- shared/libcsiphash.la \
+ shared/nm-std-aux/libnm-std-aux.la \
$(GLIB_LIBS) \
$(NULL)