summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@gnome.org>2012-02-08 12:56:52 -0500
committerDan Winship <danw@gnome.org>2012-02-15 11:42:15 -0500
commit839eab556419b6af5046e44361bdcf14fe028d27 (patch)
treeb9183f7d2cc207e7741960a2120756043a95f847 /Makefile.am
parent0b57cc68fd4a146c9fe255f14c667ab306266c0c (diff)
downloadNetworkManager-839eab556419b6af5046e44361bdcf14fe028d27.tar.gz
Use glib-mkenums to generate enum types
Rather than generating enum classes by hand (and complaining in each file that "this should really be standard"), use glib-mkenums. Unfortunately, we need a very new version of glib-mkenums in order to deal with NM's naming conventions and to fix a few other bugs, so just import that into the source tree temporarily. Also, to simplify the use of glib-mkenums, import Makefile.glib from https://bugzilla.gnome.org/654395. To avoid having to run glib-mkenums for every subdirectory of src/, add a new "generated" directory, and put the generated enums files there. Finally, use Makefile.glib for marshallers too, and generate separate ones for libnm-glib and NetworkManager.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 912ded3a05..e407d38725 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,6 @@
+include $(GLIB_MAKEFILE)
+
SUBDIRS = \
- marshallers \
include \
libnm-util \
libnm-glib \
@@ -22,7 +23,8 @@ EXTRA_DIST = \
NetworkManager.pc.in \
intltool-extract.in \
intltool-merge.in \
- intltool-update.in
+ intltool-update.in \
+ Makefile.glib
DISTCHECK_CONFIGURE_FLAGS = \
--with-tests=yes \
@@ -42,4 +44,4 @@ CLEANFILES = cscope.in.out cscope.out cscope.po.out
.PHONY: cscope
cscope:
- cscope -b -q -R -Iinclude -ssrc -slibnm-glib -slibnm-util -smarshallers -scli/src;
+ cscope -b -q -R -Iinclude -ssrc -slibnm-glib -slibnm-util -scli/src;