summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2019-05-19 11:12:53 +0200
committerThomas Haller <thaller@redhat.com>2019-05-19 11:25:59 +0200
commitd27f6b9d0a02f709e78142fedc59eae24167b688 (patch)
treed7b085a4fc32f1cc1dc4255d79aac33a8f5ea935 /Makefile.am
parenta80c199e9e0c616b6f3ebb687c7340a2ea12e213 (diff)
downloadNetworkManager-d27f6b9d0a02f709e78142fedc59eae24167b688.tar.gz
keyfile/tests: rename core's "test-keyfile" to "test-keyfile-settings"
We already have "libnm-core/tests/test-keyfile.c" from which we build "test-keyfile". Our test binaries should be named the following: - "*/tests/test-*" - the test binary "*/tests/test-*" should be build from a source file "*/tests/test-*.c". Meaning: the source's and executable's name should correspond. - test binaries should be named uniquely. Also, because older meson versions don't like having the same binary name more than once. Rename to avoid the duplicate name.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 5520cc5b6a..80fb5a0ddf 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2622,19 +2622,19 @@ EXTRA_DIST += \
# src/settings/plugins/keyfile/tests
###############################################################################
-check_programs += src/settings/plugins/keyfile/tests/test-keyfile
+check_programs += src/settings/plugins/keyfile/tests/test-keyfile-settings
-src_settings_plugins_keyfile_tests_test_keyfile_CPPFLAGS = $(src_cppflags_test)
+src_settings_plugins_keyfile_tests_test_keyfile_settings_CPPFLAGS = $(src_cppflags_test)
-src_settings_plugins_keyfile_tests_test_keyfile_LDFLAGS = \
+src_settings_plugins_keyfile_tests_test_keyfile_settings_LDFLAGS = \
$(GLIB_LIBS) \
$(CODE_COVERAGE_LDFLAGS) \
$(SANITIZER_EXEC_LDFLAGS)
-src_settings_plugins_keyfile_tests_test_keyfile_LDADD = \
+src_settings_plugins_keyfile_tests_test_keyfile_settings_LDADD = \
src/libNetworkManagerTest.la
-$(src_settings_plugins_keyfile_tests_test_keyfile_OBJECTS): $(libnm_core_lib_h_pub_mkenums)
+$(src_settings_plugins_keyfile_tests_test_keyfile_settings_OBJECTS): $(libnm_core_lib_h_pub_mkenums)
EXTRA_DIST += \
src/settings/plugins/keyfile/tests/keyfiles/Test_Wired_Connection \