summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2019-04-14 12:00:29 +0200
committerThomas Haller <thaller@redhat.com>2019-04-14 12:59:48 +0200
commit8d911088abc7ce3f3227b28aac0fa98b83549c8f (patch)
tree2a42b282d6d32206c950b9e85361f0b648c53383 /Makefile.am
parent5eab3c99873aa7aa1dd0ab642837fa0155a52a1e (diff)
downloadNetworkManager-8d911088abc7ce3f3227b28aac0fa98b83549c8f.tar.gz
build: include c-stdaux in c-util and nettools tools
This is now a dependency for the internal tools. Add the include directive first, before upgrading the libraries.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index bfdec612b0..0b418e9779 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -206,8 +206,20 @@ DISTCLEANFILES += $(polkit_policy_DATA)
###############################################################################
+EXTRA_DIST += \
+ shared/c-stdaux/src/c-stdaux.h \
+ $(NULL)
+
+###############################################################################
+
noinst_LTLIBRARIES += shared/libcsiphash.la
+shared_libcsiphash_la_CFLAGS = \
+ $(AM_CFLAGS) \
+ -std=c11 \
+ -I$(srcdir)/shared/c-stdaux/src \
+ $(NULL)
+
shared_libcsiphash_la_CPPFLAGS = \
$(CODE_COVERAGE_CFLAGS) \
$(SANITIZER_LIB_CFLAGS) \
@@ -228,6 +240,7 @@ noinst_LTLIBRARIES += shared/libcrbtree.la
shared_libcrbtree_la_CFLAGS = \
$(AM_CFLAGS) \
-std=c11 \
+ -I$(srcdir)/shared/c-stdaux/src \
$(NULL)
shared_libcrbtree_la_CPPFLAGS = \
@@ -260,6 +273,7 @@ shared_libnacd_la_CPPFLAGS = \
-DSO_ATTACH_BPF=50 \
$(CODE_COVERAGE_CFLAGS) \
$(SANITIZER_LIB_CFLAGS) \
+ -I$(srcdir)/shared/c-stdaux/src \
-I$(srcdir)/shared/c-list/src \
-I$(srcdir)/shared/c-siphash/src \
-I$(srcdir)/shared/c-rbtree/src \