summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2020-04-05 11:47:07 +0200
committerThomas Haller <thaller@redhat.com>2020-04-10 10:27:27 +0200
commite05f35f9f1f964d295239fb985a6d23c59edbf24 (patch)
tree3dd53b7309d1c146aaa2b2a3523b5e696e4b156e /Makefile.am
parentef0c289104ebd013535a1bcfa9f476247b308bab (diff)
downloadNetworkManager-e05f35f9f1f964d295239fb985a6d23c59edbf24.tar.gz
cli: cleanup NMCCommand and declarations of func implementations
- move the main func declarations to nmcli.h and give them a common prefix "nmc_command_func_" prefix. - remove some of the header files that are now empty. In fact, these headers did not really declare some well separated module. While we probably should structure the code in nmcli better with better layering, it was not and still is not. Having these dummy headers don't mean that the code is well structured and they serve little purpose. - move the static NMCommand lists variables into the function scope where they are used.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 0 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 04c767adb2..5cff6eb12f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4481,9 +4481,7 @@ clients_cli_nmcli_SOURCES = \
clients/cli/utils.c \
clients/cli/utils.h \
clients/cli/agent.c \
- clients/cli/agent.h \
clients/cli/general.c \
- clients/cli/general.h \
clients/cli/connections.c \
clients/cli/connections.h \
clients/cli/devices.c \