summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLubomir Rintel <lkundrak@v3.sk>2017-12-26 09:28:54 +0100
committerLubomir Rintel <lkundrak@v3.sk>2018-01-08 10:15:29 +0100
commitcd476e4dc922f0acfd65b02639032ee67339ad95 (patch)
treede3b396fe5a6ad5944c692ad4a953dc5b91bfcb9 /Makefile.am
parentda4c9e51a038279e261b896e5156308adaea4572 (diff)
downloadNetworkManager-cd476e4dc922f0acfd65b02639032ee67339ad95.tar.gz
core: load jansson on demand
Avoid using it if the symbols clash is detected.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 8 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index c7b8a1b8f7..8584866405 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -516,6 +516,14 @@ libnm_core_lib_c_real = \
libnm-core/nm-utils.c \
libnm-core/nm-vpn-editor-plugin.c \
libnm-core/nm-vpn-plugin-info.c
+
+if WITH_JSON_VALIDATION
+libnm_core_lib_h_priv += \
+ libnm-core/nm-jansson.h
+libnm_core_lib_c_real += \
+ libnm-core/nm-jansson.c
+endif
+
libnm_core_lib_c_mkenums = \
libnm-core/nm-core-enum-types.c
@@ -596,10 +604,6 @@ libnm_core_libnm_core_la_LIBADD = \
$(UUID_LIBS) \
$(LIBUDEV_LIBS)
-if WITH_JSON_VALIDATION
-libnm_core_libnm_core_la_LIBADD += $(JANSSON_LIBS)
-endif
-
libnm_core_libnm_core_la_LDFLAGS = \
$(CODE_COVERAGE_LDFLAGS)