summaryrefslogtreecommitdiff
path: root/src/iface-location/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/iface-location/Makefile.am')
-rw-r--r--src/iface-location/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/src/iface-location/Makefile.am b/src/iface-location/Makefile.am
new file mode 100644
index 000000000..eba44f1a1
--- /dev/null
+++ b/src/iface-location/Makefile.am
@@ -0,0 +1,32 @@
+
+AM_CFLAGS = $(CODE_COVERAGE_CFLAGS)
+AM_LDFLAGS = $(CODE_COVERAGE_LDFLAGS)
+
+noinst_LTLIBRARIES = libmmifacelocation.la
+
+libmmifacelocation_la_CPPFLAGS = \
+ $(MM_CFLAGS) \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/include \
+ -I$(top_builddir)/include \
+ -I$(top_srcdir)/src \
+ -I$(top_builddir)/src \
+ -I$(top_srcdir)/src/port \
+ -I$(top_builddir)/src/port \
+ -I$(top_srcdir)/src/helpers \
+ -I$(top_builddir)/src/helpers \
+ -I$(top_srcdir)/libmm-glib \
+ -I${top_srcdir}/libmm-glib/generated \
+ -I${top_builddir}/libmm-glib/generated
+
+if WITH_QMI
+libmmifacelocation_la_CPPFLAGS += $(QMI_CFLAGS)
+endif
+
+if WITH_MBIM
+libmmifacelocation_la_CPPFLAGS += $(MBIM_CFLAGS)
+endif
+
+libmmifacelocation_la_SOURCES = \
+ mm-iface-modem-location.h \
+ mm-iface-modem-location.c