summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorpoma <pomidorabelisima@gmail.com>2016-03-20 20:39:16 +0100
committerAleksander Morgado <aleksander@aleksander.es>2016-03-21 23:44:51 +0100
commit6197a06931ffd197b4f66b92c4d729b5911e0e36 (patch)
treef2ce98bcfea3204ebc78b5d7b4fa836c2fa87c67 /configure.ac
parent342ea24e346f855f57c69a7fc1fccbbf4e12277d (diff)
downloadModemManager-6197a06931ffd197b4f66b92c4d729b5911e0e36.tar.gz
UPower signaling obsolescence
"Newer upower versions no longer emit that signal since this handled by systemd." by Michael Biebl <mbiebl@gmail.org> https://lists.freedesktop.org/archives/devkit-devel/2014-March/001575.html See also "Plans for UPower 1.0" by Richard Hughes <hughsient@gmail.com> https://lists.freedesktop.org/archives/devkit-devel/2013-January/001339.html Signed-off-by: poma <pomidorabelisima@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 2 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 9f6b9c3fe..357405899 100644
--- a/configure.ac
+++ b/configure.ac
@@ -186,7 +186,7 @@ dnl-----------------------------------------------------------------------------
dnl Suspend/resume support
dnl
-AC_ARG_WITH(suspend-resume, AS_HELP_STRING([--with-suspend-resume=no|upower|systemd], [Build ModemManager with specific suspend/resume support]))
+AC_ARG_WITH(suspend-resume, AS_HELP_STRING([--with-suspend-resume=no|systemd], [Build ModemManager with specific suspend/resume support]))
if test "x$with_suspend_resume" = "x"; then
with_suspend_resume="none"
@@ -196,20 +196,16 @@ case $with_suspend_resume in
none)
AC_DEFINE(WITH_SUSPEND_RESUME, 0, [Define if you have suspend-resume support])
;;
- upower)
- AC_DEFINE(WITH_SUSPEND_RESUME, 1, [Define if you have suspend-resume support])
- ;;
systemd)
PKG_CHECK_MODULES(SYSTEMD_INHIBIT, [libsystemd >= 209],,
[PKG_CHECK_MODULES(SYSTEMD_INHIBIT, [libsystemd-login >= 183])])
AC_DEFINE(WITH_SUSPEND_RESUME, 1, [Define if you have suspend-resume support])
;;
*)
- AC_MSG_ERROR(--with-suspend-resume must be one of [none, upower, systemd])
+ AC_MSG_ERROR(--with-suspend-resume must be one of [none, systemd])
;;
esac
-AM_CONDITIONAL(SUSPEND_RESUME_UPOWER, test "x$with_suspend_resume" = "xupower")
AM_CONDITIONAL(SUSPEND_RESUME_SYSTEMD, test "x$with_suspend_resume" = "xsystemd")
dnl-----------------------------------------------------------------------------