summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Williams <dcbw@redhat.com>2011-04-27 14:47:00 -0500
committerDan Williams <dcbw@redhat.com>2011-04-27 14:47:00 -0500
commitc96db0c91b8c86f1c60e463f1ae133bef5cc2103 (patch)
tree6179ec77b728177354330644e67e6bd9277655fe /configure.ac
parent383bf8c9a3409fda655b18ba6ada503367b5d332 (diff)
downloadModemManager-c96db0c91b8c86f1c60e463f1ae133bef5cc2103.tar.gz
Revert "build: don't require intltool unless --with-polkit=yes"
This reverts commit 0299cf51c4cf587f79771fe219c6154bf0d0139e.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 7 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 4f7dabd75..436461f3f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,9 +21,14 @@ dnl Initialize libtool
LT_PREREQ([2.2])
LT_INIT
+dnl
+dnl translation support
+dnl
GETTEXT_PACKAGE=ModemManager
AC_SUBST(GETTEXT_PACKAGE)
AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE", [Gettext package])
+IT_PROG_INTLTOOL([0.35.0])
+AM_GLIB_GNU_GETTEXT
PKG_CHECK_MODULES(MM, dbus-glib-1 >= 0.86 glib-2.0 >= 2.18 gmodule-2.0 gobject-2.0)
@@ -66,10 +71,6 @@ case $with_polkit in
# Check for polkit_authority_get_sync()
AC_CHECK_LIB([polkit-gobject-1], [polkit_authority_get_sync], ac_have_pk_auth_get_sync="1", ac_have_pk_auth_get_sync="0")
AC_DEFINE_UNQUOTED(HAVE_POLKIT_AUTHORITY_GET_SYNC, $ac_have_pk_auth_get_sync, [Define if you have a polkit with polkit_authority_get_sync()])
-
- # translation support for policy files
- IT_PROG_INTLTOOL([0.35.0])
- AM_GLIB_GNU_GETTEXT
;;
*)
with_polkit=no
@@ -162,4 +163,6 @@ echo Building PPP-enabled tests: ${have_pppd_headers}
echo
echo Building with PolicyKit support: ${with_polkit}
echo
+echo Building with Location API support: ${with_location_api}
+echo