summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAleksander Morgado <aleksander@aleksander.es>2015-12-28 23:28:45 +0100
committerAleksander Morgado <aleksander@aleksander.es>2016-01-24 17:23:18 +0100
commitf8ba106a20d678e50619c5bf3f1a9e3c61b3463f (patch)
tree6beb70144be8a1d383376894f3b0de72991388c0 /configure.ac
parent1bdb1a558a05970e436e562cc3f8d3f43640933a (diff)
downloadModemManager-f8ba106a20d678e50619c5bf3f1a9e3c61b3463f.tar.gz
port-qmi: support new Qualcomm chipsets working always in raw-ip
The port opening logic is changed completely. Before this change, the logic would only try 802.3 setting via CTL when the QmiDevice was being open. With this new change, instead, we'll use WDA and the new libqmi APIs to query the link layer protocol expected by both the device and the kernel. If the LLP matches in both, we assume we're done; if they differ we'll try to update the LLP expected by the kernel to the one setup in WDA. This change will allow us to run with the modem using raw-ip if that is what WDA reports by default. Also bumped the libqmi version to 1.13.6, which has support for the new required APIs.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8e8bda4e9..26711ae5b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -289,7 +289,7 @@ dnl-----------------------------------------------------------------------------
dnl QMI support (enabled by default)
dnl
-LIBQMI_VERSION=1.13.5
+LIBQMI_VERSION=1.13.6
AC_ARG_WITH(qmi, AS_HELP_STRING([--without-qmi], [Build without QMI support]), [], [with_qmi=yes])
AM_CONDITIONAL(WITH_QMI, test "x$with_qmi" = "xyes")