summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAleksander Morgado <aleksander@aleksander.es>2016-03-15 12:28:56 +0100
committerAleksander Morgado <aleksander@aleksander.es>2016-03-15 19:15:25 +0100
commiteeb9e2bdcc8001d77d2b81ad6e2275fe634c4469 (patch)
tree6b0f85876e88218469cf171cdeecc40fa5fd523f /Makefile.am
parentf9c63bfa058bdab29e00f13a0bedf4b4af39797e (diff)
downloadModemManager-eeb9e2bdcc8001d77d2b81ad6e2275fe634c4469.tar.gz
build: end all multiline list variables with $(NULL)
So that appending a new item in the list only inserts one new line (i.e. the last $(NULL) is the last item always).
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am32
1 files changed, 27 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 762306ff5..0438423b4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,27 +1,49 @@
-SUBDIRS = . build-aux data include libqcdm libwmc libmm-glib src plugins cli vapi introspection uml290 po test examples docs
+SUBDIRS = \
+ . \
+ build-aux \
+ data \
+ include \
+ libqcdm \
+ libwmc \
+ libmm-glib \
+ src \
+ plugins \
+ cli \
+ vapi \
+ introspection \
+ uml290 \
+ po \
+ test \
+ examples \
+ docs \
+ $(NULL)
DISTCHECK_CONFIGURE_FLAGS = \
--with-udev-base-dir="$$dc_install_base" \
--with-systemdsystemunitdir="$$dc_install_base/$(SYSTEMD_UNIT_DIR)" \
- --enable-gtk-doc=yes
+ --enable-gtk-doc=yes \
+ $(NULL)
INTLTOOL_FILES = \
intltool-extract.in \
intltool-merge.in \
- intltool-update.in
+ intltool-update.in \
+ $(NULL)
DISTCLEANFILES = \
intltool-extract \
intltool-merge \
intltool-update \
- po/.intltool-merge-cache
+ po/.intltool-merge-cache \
+ $(NULL)
EXTRA_DIST = \
$(INTLTOOL_FILES) \
autogen.sh \
gtester.make \
- COPYING.LIB
+ COPYING.LIB \
+ $(NULL)
ACLOCAL_AMFLAGS = -I m4