summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDan Williams <dcbw@redhat.com>2010-02-16 11:03:16 -0800
committerDan Williams <dcbw@redhat.com>2010-02-16 11:03:16 -0800
commit9c958c99bc7621fc800617246e5a9fa4bc4d48c8 (patch)
treea6207ba5dbb97922e1e9205712d3cad0534db845 /Makefile.am
parent1a7be4a379e95a0ceb5ed1d30540eaf75354f27f (diff)
downloadModemManager-9c958c99bc7621fc800617246e5a9fa4bc4d48c8.tar.gz
build: add intltool support for PolicyKit policy translations
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 13 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 915f82e5f..f271b9cbc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,7 +19,7 @@ all: $(GENERATED_FILES)
CLEANFILES = $(GENERATED_FILES)
endif
-SUBDIRS = marshallers src plugins introspection test
+SUBDIRS = marshallers src plugins introspection po test
dbusservicedir = $(DBUS_SYS_DIR)
dbusservice_DATA = org.freedesktop.ModemManager.conf
@@ -39,13 +39,22 @@ edit = @sed \
DISTCHECK_CONFIGURE_FLAGS = --with-udev-base-dir=$dc_install_base
-DISTCLEANFILES = \
- $(dbusactivation_DATA)
+INTLTOOL_FILES = \
+ intltool-extract.in \
+ intltool-merge.in \
+ intltool-update.in
+DISTCLEANFILES = \
+ $(dbusactivation_DATA) \
+ intltool-extract \
+ intltool-merge \
+ intltool-update \
+ po/.intltool-merge-cache
EXTRA_DIST = \
doc-generator.xsl \
$(dbusservice_DATA) \
- $(dbusactivation_in_files)
+ $(dbusactivation_in_files) \
+ $(INTLTOOL_FILES)
ACLOCAL_AMFLAGS = -I m4