summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDan Williams <dcbw@redhat.com>2010-02-26 18:01:55 -0800
committerDan Williams <dcbw@redhat.com>2010-02-26 18:01:55 -0800
commit438a047935f941e8f7d8df27a0069c70e4b4ea05 (patch)
tree8933f938d30e44ec4acb8f4a1c775789de90e9ae /Makefile.am
parentb9958e6ec5115822b1c2112da5ef2652aa847a51 (diff)
downloadModemManager-438a047935f941e8f7d8df27a0069c70e4b4ea05.tar.gz
core: add authorization providers and optional PolicyKit support
When the support is complete, use --with-polkit to enable PolicyKit support. It's not there yet, but this commit adds an authorization provider framework which will be extended to allow hooking into PolicyKit.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 860956bf2..13ecde667 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,7 +19,11 @@ all: $(GENERATED_FILES)
CLEANFILES = $(GENERATED_FILES)
endif
-SUBDIRS = marshallers src plugins introspection po policy test
+SUBDIRS = marshallers src plugins introspection po test
+
+if WITH_POLKIT
+SUBDIRS += policy
+endif
dbusservicedir = $(DBUS_SYS_DIR)
dbusservice_DATA = org.freedesktop.ModemManager.conf