summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDan Williams <dcbw@redhat.com>2009-06-28 14:05:05 -0400
committerDan Williams <dcbw@redhat.com>2009-06-28 14:05:05 -0400
commit6077763d90b69cfc60b23f383c4529f966facaaf (patch)
tree81ae20133a6ea116d58ddc2ee86644f4e1c9eb0a /Makefile.am
parent112f2da19dbe8dcd8f32b998459298e7c1884c67 (diff)
downloadModemManager-6077763d90b69cfc60b23f383c4529f966facaaf.tar.gz
asynchronous and deferred port detection
Allow plugins to perform asynchronous port detection, and to defer port detection until later. This moves the prober bits into MMPluginBase so that all plugins can take adavantage of it only when needed; the probing is not done at udev time. Furthermore, plugins like Novatel can flip the secondary ports over the AT mode through deferred detection, by deferring the secondary ports until the main port has been detected and AT$NWDMAT has been sent. This commit also finishes the port of the rest of the plugins (except mbm) over to the new port detection methods and plugin API.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 0964e1bb4..f7e7f7deb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,7 +20,7 @@ clean:
rm -f $(GENERATED_FILES)
endif
-SUBDIRS = marshallers callouts src plugins introspection test
+SUBDIRS = marshallers src plugins introspection test
dbusservicedir = $(DBUS_SYS_DIR)
dbusservice_DATA = org.freedesktop.ModemManager.conf