summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJannis Pohlmann <jannis.pohlmann@codethink.co.uk>2012-03-23 11:10:42 +0000
committerJannis Pohlmann <jannis.pohlmann@codethink.co.uk>2012-03-23 13:19:36 +0000
commit81771871c53d24a084b54d116085028329312cf7 (patch)
treef4a66c127d8e50fcb20ad066bca2ba0332b6ebba /configure.ac
parent837f58bdadda09a13b062929d6b5d448bdb5cabe (diff)
downloadtbdiff-81771871c53d24a084b54d116085028329312cf7.tar.gz
Add new tbdiff-update command to apply a patch to a system.
This command is written in bash and takes four parameters: * a device with a btrfs file system to mount * the source subvolume name * the target subvolume name * the path to a patch file or stream It then creates the target subvolume as a snapshot of the source subvolume, applies the patch in there, then creates a <target>-run snapshot and copies the boot files (vmlinuz, extlinux.conf) to the root file system. Lastly, it adjusts extlinux.conf to point to the -run snapshot.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8c68def..320cf86 100644
--- a/configure.ac
+++ b/configure.ac
@@ -106,7 +106,7 @@ dnl AC_CHECK_FUNCS([])
dnl ************************************
dnl *** Check for required libraries ***
dnl ************************************
-dnl AC_CHECK_LIBS([])
+AC_CHECK_LIB([attr], [lsetxattr])
dnl ***********************************
dnl *** Check for required packages ***
@@ -119,6 +119,7 @@ tbdiff/Makefile
tbdiff/tbdiff-1.pc
tbdiff-create/Makefile
tbdiff-deploy/Makefile
+tbdiff-update/Makefile
tests/Makefile
])