summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py18
1 files changed, 10 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index b27b9d5..e214c33 100644
--- a/setup.py
+++ b/setup.py
@@ -1,19 +1,21 @@
#!/usr/bin/python
#
-# Copyright (C) 2012 Codethink Limited
+# Copyright (C) 2012-2014 Codethink Limited
from distutils.core import setup
+import glob
setup(name='lorry-controller',
- description='FIXME',
- long_description='''\
-FIXME
-''',
- author='Daniel Silverstone',
- author_email='daniel.silverstne@codethink.co.uk',
+ description='Run Lorry on remote repositories in a controller manner',
+ author='Codethink Ltd',
+ author_email='baserock-dev@baserock.org',
url='http://www.baserock.com/',
- scripts=['lorry-controller'],
+ scripts=['lorry-controller-webapp', 'lorry-controller-minion'],
packages=['lorrycontroller'],
+ data_files=[
+ ('share/lorry-controller/templates', glob.glob('templates/*')),
+ ('share/lorry-controller/static', glob.glob('static/*')),
+ ],
)