summaryrefslogtreecommitdiff
path: root/strata/cpe-wrt/uhttpd2.morph
diff options
context:
space:
mode:
Diffstat (limited to 'strata/cpe-wrt/uhttpd2.morph')
-rw-r--r--strata/cpe-wrt/uhttpd2.morph17
1 files changed, 17 insertions, 0 deletions
diff --git a/strata/cpe-wrt/uhttpd2.morph b/strata/cpe-wrt/uhttpd2.morph
new file mode 100644
index 00000000..f7106582
--- /dev/null
+++ b/strata/cpe-wrt/uhttpd2.morph
@@ -0,0 +1,17 @@
+name: uhttp2
+kind: chunk
+
+pre-configure-commands:
+- sed -i 's/-Werror//' CMakeLists.txt
+
+configure-commands:
+- cmake -DCMAKE_INSTALL_PREFIX=$PREFIX
+
+build-commands:
+- make
+
+install-commands:
+- make install
+
+post-install-commands:
+- install -d "$DESTDIR$PREFIX/sbin" && cd "$DESTDIR$PREFIX/sbin" && ln -s ../.."$PREFIX"/bin/uhttpd