summaryrefslogtreecommitdiff
path: root/strata/cpe-wrt/procd.morph
diff options
context:
space:
mode:
Diffstat (limited to 'strata/cpe-wrt/procd.morph')
-rw-r--r--strata/cpe-wrt/procd.morph9
1 files changed, 8 insertions, 1 deletions
diff --git a/strata/cpe-wrt/procd.morph b/strata/cpe-wrt/procd.morph
index 7e85cab9..fc0fcabe 100644
--- a/strata/cpe-wrt/procd.morph
+++ b/strata/cpe-wrt/procd.morph
@@ -3,4 +3,11 @@ kind: chunk
pre-configure-commands:
- sed -i "s/-Werror//" CMakeLists.txt
-- sed -i "s/#include <json/#include <json-c/" service/validate.c plug/hotplug.c
+- sed -i "s/#include <json>/#include <json-c>/" service/validate.c plug/hotplug.c
+
+build-commands:
+- cmake -DCMAKE_INSTALL_PREFIX=/
+- make
+
+install-commands:
+- make install