summaryrefslogtreecommitdiff
path: root/strata/core/cmake.morph
diff options
context:
space:
mode:
Diffstat (limited to 'strata/core/cmake.morph')
-rw-r--r--strata/core/cmake.morph5
1 files changed, 5 insertions, 0 deletions
diff --git a/strata/core/cmake.morph b/strata/core/cmake.morph
index 1d310ef4..97b264e4 100644
--- a/strata/core/cmake.morph
+++ b/strata/core/cmake.morph
@@ -1,5 +1,10 @@
name: cmake
kind: chunk
+pre-configure-commands:
+# Missing header include
+- echo "#include <sys/stat.h>" >> Source/cmStandardIncludes.h
+# Prevent segfault when boostrapping and looking for curses library
+- sed -i 's/NOT CMAKE_SYSTEM_NAME MATCHES syllable/0/' CMakeLists.txt
configure-commands:
- ./bootstrap --prefix="$PREFIX" --docdir=/share/doc/cmake --mandir=/share/man
build-commands: