summaryrefslogtreecommitdiff
path: root/strata/cpe-wrt/procd.morph
diff options
context:
space:
mode:
authorSimon Hoinkis <simon.hoinkis@codethink.co.uk>2015-03-13 15:33:22 +0000
committerRichard Dale <richard.dale@codethink.co.uk>2015-05-19 16:56:06 +0100
commitfabec9d8a13ddc1be7b85f71874af527569530d6 (patch)
tree252a44bfa1170c85cde8c50abe67794313fb4e93 /strata/cpe-wrt/procd.morph
parent2e9ff9e129b016d0f8caf04a8bcd25130d08fc09 (diff)
downloaddefinitions-fabec9d8a13ddc1be7b85f71874af527569530d6.tar.gz
Add base-files to cpe-wrt
Diffstat (limited to 'strata/cpe-wrt/procd.morph')
-rw-r--r--strata/cpe-wrt/procd.morph9
1 files changed, 8 insertions, 1 deletions
diff --git a/strata/cpe-wrt/procd.morph b/strata/cpe-wrt/procd.morph
index 7e85cab9..fc0fcabe 100644
--- a/strata/cpe-wrt/procd.morph
+++ b/strata/cpe-wrt/procd.morph
@@ -3,4 +3,11 @@ kind: chunk
pre-configure-commands:
- sed -i "s/-Werror//" CMakeLists.txt
-- sed -i "s/#include <json/#include <json-c/" service/validate.c plug/hotplug.c
+- sed -i "s/#include <json>/#include <json-c>/" service/validate.c plug/hotplug.c
+
+build-commands:
+- cmake -DCMAKE_INSTALL_PREFIX=/
+- make
+
+install-commands:
+- make install