summaryrefslogtreecommitdiff
path: root/strata/cpe-wrt/iptables.morph
diff options
context:
space:
mode:
authorRichard Dale <richard.dale@codethink.co.uk>2015-06-12 16:11:41 +0100
committerRichard Dale <richard.dale@codethink.co.uk>2015-06-12 16:11:41 +0100
commita060feb534b853e079557004d1d00a19a4513039 (patch)
treec7739a8d5a1bc51db2fab8de5b94de593a007149 /strata/cpe-wrt/iptables.morph
parentb73be0369d74c1e903a828b6ffdba9aa35477227 (diff)
downloaddefinitions-a060feb534b853e079557004d1d00a19a4513039.tar.gz
Add an iptables chunk and configure and build as similar to the
iptables/Makefile in the openwrt repo Update the firewall3 sha1 to be the most recent
Diffstat (limited to 'strata/cpe-wrt/iptables.morph')
-rw-r--r--strata/cpe-wrt/iptables.morph19
1 files changed, 19 insertions, 0 deletions
diff --git a/strata/cpe-wrt/iptables.morph b/strata/cpe-wrt/iptables.morph
new file mode 100644
index 00000000..72a6b2b7
--- /dev/null
+++ b/strata/cpe-wrt/iptables.morph
@@ -0,0 +1,19 @@
+name: iptables
+kind: chunk
+
+configure-commands:
+- autoreconf -ivf
+- |
+ ./configure --enable-shared \
+ --enable-devel \
+ --with-xtlibdir=/usr/lib/iptables \
+ --enable-static \
+ --prefix=$PREFIX
+
+build-commands:
+- make CFLAGS="-ffunction-sections -fdata-sections -DNO_LEGACY" LDFLAGS="-lm"
+
+install-commands:
+- make install
+- install extensions/libiptext*.so $DESTDIR$PREFIX/lib/
+