summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Hoinkis <simon.hoinkis@codethink.co.uk>2015-03-06 10:51:40 +0000
committerRichard Dale <richard.dale@codethink.co.uk>2015-05-19 16:56:06 +0100
commite28209fd29c35accd7694eeed1640e8ffab3a136 (patch)
treecd70fabc0fe7791059ddccf86ef1532c3efbfe91
parentffa9fed7f18e900824e2b5d3657c34f2b46d5b18 (diff)
downloaddefinitions-e28209fd29c35accd7694eeed1640e8ffab3a136.tar.gz
Add fstools and netifd to cpe-wrt
-rw-r--r--strata/cpe-wrt.morph19
-rw-r--r--strata/cpe-wrt/fstools.morph5
-rw-r--r--strata/cpe-wrt/netifd.morph8
3 files changed, 31 insertions, 1 deletions
diff --git a/strata/cpe-wrt.morph b/strata/cpe-wrt.morph
index 9d68bd85..23f90440 100644
--- a/strata/cpe-wrt.morph
+++ b/strata/cpe-wrt.morph
@@ -54,4 +54,21 @@ chunks:
build-depends:
- ubus
- uci
-
+- name: fstools
+ morph: strata/cpe-wrt/fstools.morph
+ repo: upstream:fstools
+ ref: 1c1bfa053103f7783167d2ab272fb11331f87681
+ unpetrify-ref:
+ build-depends:
+ - libubox
+ - uci
+- name: netifd
+ morph: strata/cpe-wrt/netifd.morph
+ repo: upstream:netifd
+ ref: 4d84111e1014c817653db92bcd8024ff1935b6be
+ unpetrify-ref:
+ build-depends:
+ - json-c
+ - libubox
+ - uci
+ - ubus
diff --git a/strata/cpe-wrt/fstools.morph b/strata/cpe-wrt/fstools.morph
new file mode 100644
index 00000000..cf5a730a
--- /dev/null
+++ b/strata/cpe-wrt/fstools.morph
@@ -0,0 +1,5 @@
+name: fstools
+kind: chunk
+
+pre-configure-commands:
+- sed -i "s/-Werror//" CMakeLists.txt
diff --git a/strata/cpe-wrt/netifd.morph b/strata/cpe-wrt/netifd.morph
new file mode 100644
index 00000000..0d8c835c
--- /dev/null
+++ b/strata/cpe-wrt/netifd.morph
@@ -0,0 +1,8 @@
+name: netifd
+kind: chunk
+
+pre-configure-commands:
+- sed -i "s/-Werror//" CMakeLists.txt
+- sed -i "s/netifd\s\${LIBS}/netifd \${LIBS} \${LIBNL_LIBRARIES} \${JSONC_LIBARIES}/" CMakeLists.txt
+- sed -i "s/#include\s\"config.h\"/#include \"config.h\"\n#include \"bits.h\"/" handler.h
+- sed -i "s/SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS \"\")/SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS \"\")\nINCLUDE(FindPkgConfig)\nPKG_CHECK_MODULES(JSONC json-c)\nIF(JSONC_FOUND)\n ADD_DEFINITIONS(-DJSONC)\n INCLUDE_DIRECTORIES(${JSONC_INCLUDE_DIRS})\nENDIF()\n\nPKG_CHECK_MODULES(LIBNL libnl-3.0)\nINCLUDE_DIRECTORIES(${LIBNL_INCLUDE_DIRS})\n/" CMakeLists.txt