summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Dale <richard.dale@codethink.co.uk>2015-05-22 08:38:38 +0100
committerRichard Dale <richard.dale@codethink.co.uk>2015-05-22 08:38:38 +0100
commit192818a59438625ca7e2b5823673f4fff68bbecc (patch)
tree72b1d3467acc4c1605d75ff28bfb909e3a08a0ee
parent02b90aef3f01ce7c29aab888cd1543088ced0ad1 (diff)
downloaddefinitions-192818a59438625ca7e2b5823673f4fff68bbecc.tar.gz
Install missing config files
-rw-r--r--strata/cpe-wrt/base-files.morph6
-rw-r--r--strata/cpe-wrt/dropbear.morph2
-rw-r--r--strata/cpe-wrt/netifd.morph8
3 files changed, 14 insertions, 2 deletions
diff --git a/strata/cpe-wrt/base-files.morph b/strata/cpe-wrt/base-files.morph
index 297cf98d..eb9f66cf 100644
--- a/strata/cpe-wrt/base-files.morph
+++ b/strata/cpe-wrt/base-files.morph
@@ -16,6 +16,7 @@ install-commands:
- install -d $DESTDIR/etc/init.d
- install -d $DESTDIR/etc/rc.d
+- install -d $DESTDIR/etc/config
- cp -r package/network/config/netifd/files/* "$DESTDIR"/
- install package/system/ubox/files/log.init "$DESTDIR"/etc/init.d/log
- cp -r package/system/uci/files/* "$DESTDIR"/
@@ -27,3 +28,8 @@ install-commands:
- install package/system/rpcd/files/rpcd.init "$DESTDIR"/etc/init.d/rpcd
- install package/system/mountd/files/mountd.init "$DESTDIR"/etc/init.d/mountd
- install package/network/config/firewall/files/firewall.init "$DESTDIR"/etc/init.d/firewall
+
+- install package/network/services/dnsmasq/files/dhcp.conf "$DESTDIR"/etc/config/dhcp
+- install package/network/services/dropbear/files/dropbear.config "$DESTDIR"/etc/config/dropbear
+- install package/network/config/firewall/files/firewall.config "$DESTDIR"/etc/config/firewall
+- install package/network/services/uhttpd/files/uhttpd.config "$DESTDIR"/etc/config/uhttpd
diff --git a/strata/cpe-wrt/dropbear.morph b/strata/cpe-wrt/dropbear.morph
index 1a9b0002..fc2f8fb4 100644
--- a/strata/cpe-wrt/dropbear.morph
+++ b/strata/cpe-wrt/dropbear.morph
@@ -12,5 +12,5 @@ install-commands:
- make PROGRAMS="dropbear dbclient dropbearkey dropbearconvert scp" DESTDIR=$DESTDIR install
post-install-commands:
-- install -d "$DESTDIR/sbin" && cd "$DESTDIR/sbin" && ln -s ..$PREFIX/sbin/dropbear ssh
+- install -d "$DESTDIR$PREFIX/bin" && cd "$DESTDIR$PREFIX/bin" && ln -s ../sbin/dropbear ssh
diff --git a/strata/cpe-wrt/netifd.morph b/strata/cpe-wrt/netifd.morph
index df520d77..b9408b9d 100644
--- a/strata/cpe-wrt/netifd.morph
+++ b/strata/cpe-wrt/netifd.morph
@@ -8,9 +8,15 @@ pre-configure-commands:
- sed -i "s/#include <json/#include <json-c/" handler.c handler.h
- sed -i "s/SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS \"\")/SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS \"\")\nINCLUDE(FindPkgConfig)\nPKG_CHECK_MODULES(JSONC json-c)\nIF(JSONC_FOUND)\n ADD_DEFINITIONS(-DJSONC)\n INCLUDE_DIRECTORIES(${JSONC_INCLUDE_DIRS})\nENDIF()\n\nPKG_CHECK_MODULES(LIBNL libnl-3.0)\nINCLUDE_DIRECTORIES(\${LIBNL_INCLUDE_DIRS})\n/" CMakeLists.txt
-build-commands:
+configure-commands:
- cmake -DCMAKE_INSTALL_PREFIX=$PREFIX -DLIBNL_LIBS=-lnl-tiny -DLIBNL_INCLUDE_DIRS=/usr/include/libnl-tiny
+
+build-commands:
- make
install-commands:
- make install
+- install -d "$DESTDIR"/lib/netifd
+- install scripts/* "$DESTDIR"/lib/netifd
+- install -d "$DESTDIR"/etc/config
+- install config/* "$DESTDIR"/etc/config