summaryrefslogtreecommitdiff
path: root/strata/build-essential.morph
Commit message (Collapse)AuthorAgeFilesLines
* Upgrade to GCC 5.1jjardon/gcc_5_1_0Javier Jardon2015-04-271-10/+10
| | | | Change-Id: Iad8f11341a4a770c14393a50d1b0d3e26c076dbf
* strata/build-essential: Upgrade linux-api-headers to 4.0Javier Jardón2015-04-141-6/+6
| | | | Change-Id: I73ed1c3c43f341d6e09521fc8bf0c4899616e972
* Upgrade to latest glibc (2.21)Javier Jardón2015-04-071-6/+6
| | | | Change-Id: I375c0af00497f8cbedb0d9759bbb64e0034582ad
* Upgrade to latest linux kernel (3.19.2)Javier Jardón2015-03-311-6/+6
| | | | Change-Id: I850fe29ca99dd5223e39062f3b654536e69d3dda
* Add missing build-depend for gccDaniel Silverstone2015-03-261-0/+1
| | | | | | | The gcc chunk was missing one more implicit build dependency (namely that of linux-api-headers). Change-Id: Ia7de9985cfa31444efe572e0bea5dc1d31912055
* build-essential: Add note about inconsistent use of build-depends fieldSam Thursfield2015-03-261-0/+7
| | | | Change-Id: Iff40fb270a403c486e1897ecc8d8a973aec05257
* Make stage2-linux-api-headers and stage2-gawk dependencies explicitPaul Sherwood2015-03-251-0/+9
| | | | | | | | | | | As discussed on the ML at [1] morph somehow infers that stage2-linux-api-headers is required for other stage2 components. This patch makes the inference explicit, which is more consistent, and should not affect any current builds or cache calculations. Also, it seems m4 requires stage2-gawk, so make that explicit too. [1] http://listmaster.pepperfish.net/pipermail/baserock-dev-baserock.org/2015-March/012425.html
* Fix the stage 2 gawk build failureKejia Hu (Terry)2015-03-241-2/+2
| | | | | | | According to Richard Maw's comments on #baserock, the upstream gawk was broken, and we should use 4.1 stable instead Change-Id: Ifce17b2c90d80e0f1c76ac2bbc145aece74e8dd1
* Do not use 'build-depends' chunk parameter when it's empthy (and change to ↵baserock/jjardon/no_build_depends_fixJavier Jardón2015-03-061-3/+0
| | | | version: 1)
* Revert "Do not use 'build-depends' chunk parameter when it's empthy (and ↵Javier Jardón2015-03-061-0/+3
| | | | | | | | change to version: 1)" Morph should have been updated first This reverts commit ced4ed5f7aa35b46d161c5efea972699826f09de.
* Do not use 'build-depends' chunk parameter when it's empthy (and change to ↵baserock/jjardon/no_build_dependsJavier Jardón2015-03-061-3/+0
| | | | version: 1)
* strata/build-essential: Update busybox to latest (1.23.1)baserock/jjardon/busybox_1_23_1Javier Jardón2015-03-061-4/+4
|
* Merge branch 'baserock/jjardon/systemd219'Javier Jardón2015-02-251-4/+4
|\ | | | | | | | | Reviewed-by: Tiago Gomes <tiago.gomes@codethink.co.uk> Reviewed-By: Richard Maw <richard.maw@gmail.com>
| * build-essential: Upgrade linux-headers to 3.19Javier Jardón2015-02-191-4/+4
| |
* | build-essential: Ask that armv7lhf-cross-toolchain is kept up to dateSam Thursfield2015-02-201-0/+3
|/
* Update to Make 4.1Tiago Gomes2015-02-121-6/+6
|
* Update gawk to 4.1.1Tiago Gomes2015-02-121-4/+4
|
* strata/build-essential: Upgrade to latest m4 tarball (1.4.17)Javier Jardón2015-02-021-6/+6
|
* Correct unpetrify-refsTiago Gomes2015-01-261-8/+8
|
* Update GCC to 4.9.2Tiago Gomes2015-01-231-8/+21
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Update the GCC compiler to the 4.9.2 version. It turns out that a C++ compiler is required to build the latest GCC releases, so build one in stages 1 and 2 as well. The updated list of GCC configuration options that either don't work in a cross compiler or are not needed in a temporary compiler, were based on the latest instructions from Linux From Scratch. The inclusion of /lib64 in the lib path for the stage 1 linker is an attempt to turn things more robust rather than to just symlink in /lib stuff that ends up installed in /lib64 (as it is already being done for libgcc_s.so). Ideally, we should configure every chunk to install to /lib, however GCC seems to not honour the `--with-libdir` configuration flag. With this version of GCC, it looks like a sysroot needs to be given at configure time so that `--with-native-system-header-dir` does what it claims to do. Unfortunately, this has the side effect of making GCC not passing to the linker the linker sysroot flag: `-Wl,--sysroot=$SYSROOT`. The workaround is to modify LDFLAGS to give a sysroot directly to GCC, `--sysroot=$SYSROOT`, which will then be further passed down to the linker. As the newest version of GCC finds more warnings than the previous one, `-Werror` was disabled for the coreutils, GDB and Syslinux projects. Syslinux's Makefile had to be patched, as it is not possible to disable `-Werror` for all targets through the NO_WERROR variable. The hack to handle libgcc_eh being required during eglibc's build was removed, as it doesn't seem to be the case anymore.
* Move M4 from core to build-essentialTiago Gomes2015-01-231-0/+16
| | | | | M4 is required to manipulate the assembly code in GMP. GMP is a math library required to build GCC.
* Update binutils to 2.25Tiago Gomes2015-01-221-6/+6
|
* build-essential: separate each chunk definition with a line feedTiago Gomes2015-01-221-0/+22
| | | | | Although we are not using this style in any other morphologies, it makes it easier to parse.
* Fix incorrect dependency in build-essentialDaniel Silverstone2015-01-191-2/+1
| | | | | | If the BUILD system is unable to directly run TARGET binaries then it fails during the preparation of stage2-fake-bash because it incorrectly build-depends on stage2-busybox.
* strata/build-essential.morph: update ref of busyboxJavier Jardón2014-11-171-1/+1
| | | | To remove unneded systemd units
* Various patches in gcc 4.6 (stage1 and stage2)baserock/pedroalvarez/glibc10Pedro Alvarez2014-11-111-3/+3
| | | | | | | | These patches are needed to: - Support the name change of the dynamic linker in the new version of glibc. - Build gcc in x86_32. - Remove old morphology files.
* Various patches in gcc 4.7 (stage3)Pedro Alvarez2014-11-111-1/+1
| | | | | | | | These patches are needed to: - Build gcc in armv7b. - Support the name change of the dynamic linker in the new version of glibc. - Remove the old morphology files.
* Use glibc instead of eglibcPedro Alvarez2014-11-111-41/+41
|
* Add stage2-fake-bash before eglibcPedro Alvarez2014-11-111-0/+10
| | | | | This change is to prepare the transition to glibc since the latter is going to need bash to build.
* Patch busybox to be glibc-2.20 compatiblePedro Alvarez2014-11-111-2/+2
| | | | | | This patch is needed because glibc rearranged its headers to not leak as many definitions unintentionally, but busybox was relying on the leaked definitions.
* Use linux-api-headers from Linux 3.8Sam Thursfield2014-09-261-4/+4
| | | | | | The 'make mrproper' command now requires GNU Bash, but since we start from a clean Git checkout of linux.git we can just remove that from the build command list.
* Re-organise definitions with scripts/organise-morphologies.pyGENIVI-I0.1baserock/release/GENIVI-I0.1Richard Maw2014-08-181-0/+334