summaryrefslogtreecommitdiff
path: root/src/configure.in
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2013-11-03 00:41:00 +0100
committerBram Moolenaar <Bram@vim.org>2013-11-03 00:41:00 +0100
commit39766a7595461b89d1aebff72ac3853225e6a4c5 (patch)
tree00df2e3fe0c13c49f737e9b2a2b52c472b1e4873 /src/configure.in
parent0b400087d076ba1a476d753c019fbfd96d8ae58e (diff)
downloadvim-git-39766a7595461b89d1aebff72ac3853225e6a4c5.tar.gz
updated for version 7.4.061v7.4.061
Problem: Availability macros configure check in wrong place. Solution: Also check when not using Darwin. Remove version check.
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/configure.in b/src/configure.in
index 73470fc7d..ee70682b2 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -206,10 +206,6 @@ if test "`(uname) 2>/dev/null`" = Darwin; then
dnl TODO: use -arch i386 on Intel machines
CPPFLAGS="$CPPFLAGS -DMACOS_X_UNIX -no-cpp-precomp"
- dnl Mac OS X 10.9+ no longer include AvailabilityMacros.h in Carbon
- dnl so we need to include it to have access to version macros.
- AC_CHECK_HEADER(AvailabilityMacros.h, [AC_DEFINE(HAVE_AVAILABILITYMACROS_H, 1, [ Define if we have AvailabilityMacros.h on Mac OS X ])])
-
dnl If Carbon is found, assume we don't want X11
dnl unless it was specifically asked for (--with-x)
dnl or Motif, Athena or GTK GUI is used.
@@ -232,6 +228,10 @@ else
AC_MSG_RESULT(no)
fi
+dnl Mac OS X 10.9+ no longer include AvailabilityMacros.h in Carbon
+dnl so we need to include it to have access to version macros.
+AC_CHECK_HEADER(AvailabilityMacros.h, HAVE_AVAILABILITYMACROS_H=1)
+
AC_SUBST(OS_EXTRA_SRC)
AC_SUBST(OS_EXTRA_OBJ)